confused with incoming and outgoing dialpeers

Unanswered Question
Oct 1st, 2007

Hi


I have set up CCM5.1 with 3 digits long extensions (600-899). Also I have H323 GW which is c2811 with ISDN PRI E1 trunk to PSTN. From our telco we got enumeration from 553600 to 553899. When a call comes from PSTN, telco send us 4 digits. I.e. number 553700 when called, I can see in debug that called number is 3700. Even I have incoming pots dial-peer 553000 with destination-patern 3..., the router sends all 4 digits to CCM!? I've put forward-digits 3, but it's still the same. Do these commands work only for outgoing calls? In both cases, I can't see that leading digit (3) is being striped off!? Call doesn't reach the extension 700, phone with line 700 doesn't ring, and finaly after 1 ring telco gives me the unassigned number error. How should I set dial-peers?


Generaly, I need to set up CCM and gws in order to when somebody calls 553XYZ, the extension XYZ is being ringed.


Here is the part of my router 2811 config:


!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

!

!

voice-port 0/0/0:15

!

!

!

!

dial-peer voice 1010 voip

destination-pattern 553...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1011 voip

preference 2

destination-pattern 553...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.2

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1021 voip

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1022 voip

preference 2

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.2

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 553000 pots

incoming called-number 3...

direct-inward-dial

port 0/0/0:15

forward-digits 3

!

gateway

timer receive-rtp 1200

!



I'm confused with incoming and outgoing dial-peer configuration. Dialpeer 553000 was ment to be incoming dialpeer, and dialpeers 1021 and 1022 were ment to be outgoing dialpeers (towards CCM). Actually, I was hoping that default dialpeer 0 as incoming dialpeer would be enough, but not. Then I've introduced dialpeer 553000, but it didn't help also. Where am I wrong?


TIA

Zoran Milenkovic

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (5 ratings)
Loading.
hoanghiep Mon, 10/01/2007 - 03:23

The dial-peer 553000 works as incoming dial-peer for calls coming in from PSTN, so it doesnot strip the leading number (3).

You can configure the gateway in CallManager to receive only 3 digits (in CallManager -> Voice Gateway -> Call Routing Information -> Inbound calls, you left the Significant digits fields with the default value (all digits), I guess)

You can delete the dial-peer 1010 and 1011 as they are not necessary; in dial-peer voice 553000 you can delete all command but "incoming called number" and "port".

By the way, I saw no dial-peer for outgoing calls to PSTN.

Vote this reply if it's useful for you.

hoanghiep

mchandak Mon, 10/01/2007 - 04:45

forward-digits command only works on outgoing dial-peer and not incoming. From what I can see this has been configured on the incoming dial-peer so the same is not being applied. You would have to configure the same on your "voip dial-peer" which sends the call to CM.


Another option which you can use is on CallManager, under Gateway configuration, you can set "Significant Digits" as 3, when this is done, CM would route calls based on the last 3 digits being recieved from the Gateway.


Hope this helps

mizoran78 Mon, 10/01/2007 - 05:13

Hi hoanghiep and mchandak!


Thanks for replies!


I'm currently implementing your suggestions. I've found "Significant Digits" field and set it already to 3.


I'm still getting unassigned number error from telco when I try to call from PSTN.


I'll get some debug info and put here.


TIA

Zoran

CapitaServicedesk Mon, 10/01/2007 - 06:17

Looking at the post it seems, the telco has given you a range of DID's i.e. 553xxx- 553xxx


The config below should help you with issue you are currently facing.

!

Dial-peer voice 1 voip

destination-pattern 553...

session target ipv4:

dtmf-relay h245-alphanumeric

/---Additionally you can chose to define codecs & other things----/

!


dial-peer voice 2 pots

incoming-called number 553...

direct-inward-dial

forward digits


Post you results, if this works.

mizoran78 Mon, 10/01/2007 - 08:20

Hi all!


My current config is the following:


dial-peer voice 1021 voip

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 1022 voip

preference 2

destination-pattern 3...

voice-class codec 1

voice-class h323 1

session target ipv4:10.0.9.2

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 553000 pots

description Calls from PSTN

incoming called-number 3...

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 9 pots

description calls towards PSTN

destination-pattern 9T

port 0/0/0:15



hoanghiep,


I tried everything you suggested, but I couldn't remove direct-inward-dial from dialpeer 553000 cause it makes two-stage dialing. After dialing I get second dial tone which is not desirable with DID numbers. Anyway, with direct-inward-dial I get "Number not in use error" :(


mchandak!


As for configuring significant digits, I did it in CCM -> Gateway config, since it's not possible to put forward-digits command on voip dialpeer!


CapitaServicedesk!


I'll give a try and let you know if it works.


All,


If somebody have working configuration with DID numbers and E1/ISDN-PRI, please share it! It is not about some bug here, I just have no enough experience with CCM to make it working.


TIA

Zoran



Debug voice ccapi inout is in attach



mizoran78 Mon, 10/01/2007 - 10:31

Hi guys!


I have to apologize! Incoming calls (from PSTN) came up to work after rebooting CCM! So that means that dialpeer 553000 is OK. Again, I'm sorry I didn't realize that reboot can be so powerful cure for CCM 5.1!?


The dialpeer that still gives me a hard time is outgoing dialpeer 9. Calls from inside get established for a second and then get disconnected.


I'm providing debug voice ccapi inout and debug isdn q931 in attach. Please can anybody help me about this.


TIA

Zoran



Paolo Bevilacqua Thu, 10/04/2007 - 14:53

Hi,


Both disconnects are strange. Which IOS are you using? can you upgrade to 12.4(11)XJ4 that has known bugs fixed, and try again ?

Actions

This Discussion