How to set clock on a cisco device?

Answered Question
Oct 1st, 2007

Hi I have NTP servers, timezones and summertime set up on our devices, but while 'show clock' does show the correct time (without the star too), 'show log' runs one hour behind.

What can I do to sort it out?

Thank you.

I have this problem too.
0 votes
Correct Answer by Danilo Dy about 9 years 2 months ago

Hi,

Apply the following config

service timestamps debug datetime msec show-timezone localtime

service timestamps log datetime msec show-timezone localtime

Regards,

Dandy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Danilo Dy Mon, 10/01/2007 - 05:58

Hi,

Apply the following config

service timestamps debug datetime msec show-timezone localtime

service timestamps log datetime msec show-timezone localtime

Regards,

Dandy

VictorAKur Mon, 10/01/2007 - 06:12

Thank you very much - one question - why 'service timestamps debug datetime msec show-timezone localtime' ?

Danilo Dy Mon, 10/01/2007 - 06:25

Hi,

Command "service timestamps"

Options;

debug = Indicates that the timestamp should be applied to debugging messages.

log = Indicates that the timestamp should be applied to system logging messages.

uptime = Time stamp with the time since the system was rebooted. The time stamp format for uptime is HHHH:MM:SS.

datetime = Time stamp with the date and time. The time stamp format for datetime is MMM DD HH:MM:SS.

msec = Include milliseconds in the time stamp.

localtime = Time stamp relative to the local time zone.

year = Include the year in the datetime format.

show-timezone = Include the time zone name in the time stamp.

Regards,

Dandy

Actions

This Discussion