Multicast forwarding between vlans

Unanswered Question
Oct 1st, 2007

We have just upgrade from HP gear to Cisco. I have a 6500 running IOS and it has about 10 vlans. vlan 100 has a multicasting source, there is a routed port that goes out to the Internet and all other routed interfaces are vlan SVI's. I need to be able to multicast from the source in vlan100 to the other 9 vlans. I have ip multicast-routing enabled and ip pim sparse-dense mode enabled on all vlan SVI's. Yet other vlans cannot receive the multicast. Am I missing something?

Jared H.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kevin Dorrell Mon, 10/01/2007 - 06:39

Is ip igmp snooping enabled?

What do you get for show ip igmp snooping groups? Can you see all the receivers?

Kevin Dorrell


ankbhasi Mon, 10/01/2007 - 07:22

Hi Friend,

In addition to Kevin's post also check if you see in and out interface listed in your multicast routing table with command "sh ip mroute" and also issue a command "sh ip igmp group" and check if you see your hosts from dfferent vlan as last reporter.

Also make sure you are sending multicast traffic from source in vlan 100 with TTL value higher than 1.



a.gooding Sat, 01/26/2008 - 10:35


im trying to configure multicast between vlans for two locations. the head office is fine and when i issue a sh ip mroute im seeing the two vlans bound to the 239 address. but on the remote router, im only seeeing the data vlan being bound. both are configured with sparse-dense and ive configured all sub-interfaces with this command as well.

why does it not recognise one vlan?


This Discussion