Unity upgrade questions

Unanswered Question
Oct 1st, 2007

All, I posted this last week in another forum, but I have not had any reply. Sorry for the duplicate, but in real need of help.

All, my customer wants me to upgrade their unity 4.0(3) server to unity 4.0(5) so that they can migrate to win 2003. Im not sure really even how to do the upgrade. The upgrade guide is very confusing to me, so are there any pointers from you guys out there that might help me out? This has unified messaging also as part of it with Exchange. Id appreciate the help and guidance. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Nelson Mon, 10/01/2007 - 18:27

There are a few questions that have to be asked first before the best path can be determined.

1. Are you moving to a new platform?

2. What version of Exchange are you running now?

3. Are you planning on migrating to Exchange 2007 anytime soon?

Let us know on these and we can come up with the best strategy.

Thank you,

Jon

jjoseph01 Mon, 10/01/2007 - 20:19

Answers to questions:

1. Are you moving to a new platform?

Not now. Ill be upgrading first, waiting for a small amount of time, then migrating over to a new server.

2. What version of Exchange are you running now?

Exchange 2000 at present time, not upgrading yet.

3. Are you planning on migrating to Exchange 2007 anytime soon?

Not yet.

Jon Nelson Tue, 10/02/2007 - 05:15

Since you are using Exchange 2000, your options are pretty limited. If you want to use Windows Server 2003, Cisco requires that the partner server be an Exchange 2003 server if you are using Windows Server 2003 for the OS.

At this point, I would recommend that you upgrade from 4.03 to 4.2. The upgrade is very straight forward and consists of the following steps:

Use the following guide when performing the upgrade:

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/42/upgrade/guide/ex/ex.html

1. Disable CSA

2. Install the latest approved Cisco Windows Updates

3. Run DBWalker

4. Perform a DiRT backup

5. Schedule downtime

6. Upgrade Unity in place

The key things are making sure you have a clean database and a good backup before you try the upgrade. Should they fail, you can always start over.

Thank you,

Jon

jjoseph01 Tue, 10/02/2007 - 05:51

Ok, I apologize. I was wrong about exchange for this client. They have exchange 2003 in place, and are considering 2007 in the future. Again, I was told the wrong information and I apologize.

Im sure I have many questions I cant think of, but here is what comes to mind:

1. When doing the install, do I need uninstall Unity 4.0.3 first? OR do I just install on top of it, just going with the defaults?

2. Will Dirt be the best backup utility, or should I use a third party backup?

3. Will anything in CallManager need to change?

4. Will anything in Exchange need to change?

These are my first thoughts? Sorry about this, this is my first upgrade and my confidence is very little right now. Thanks for the guidance.

jjoseph01 Tue, 10/02/2007 - 07:38

ok, Im guessing this will be a "not so bright" question, but how will I do a restore if the version of Unity is different? If I cant do the restore, will all messages be lost? etc?

Jon Nelson Tue, 10/02/2007 - 15:10

You do the install over the top of the existing Unity installation. Basically, you reinstall the application, but you don't uninstall Unity like you would Microsoft Office for example. DiRT is the only TAC supported tool for backing up Unity. I highly recommend it.

Nothing should change in CallManager or on Exchange. I would make sure that Exchange 2003 is patched to Service Pack 2 and make sure that the Exchange System Tools installed on the Unity Server are also Service Pack 2.

With regards to your second question, you can only restore a Unity backup to the same version.

Thank you,

Jon

jjoseph01 Tue, 10/02/2007 - 17:47

Thank you Jon for the advice. I appreciate it. First one Ive done, so Im learning. Thanks.

Actions

This Discussion