FXO not disconnecting from remote call

Answered Question
Oct 1st, 2007
User Badges:

Hope this is the correct place to post my issue, I'm running CCME on a 2801 with IOS c2801-ipvoicek9-mz.124-11.T.bin, I can make calls ok and also receive them ok, my problems start when I do not answer the call; I have tested this using my mobile; when I call my land line it rings as normal but if I end the call from the mobile the phone keeps ringing for another two minutes, does anybody know what is causing the FXO to hold the call for another two minutes


Many Thanks


Martyn


Correct Answer by paolo bevilacqua about 9 years 9 months ago

Please enable opx in connection plar.


"disconnect anytone" is know to now work, you must enter the precise tone definitions unless your telco can enable ground start, or power denial.

Correct Answer by paolo bevilacqua about 9 years 9 months ago

Do you use connection plar under voice-port and if so do you have opx option of the command ? That makes the router no answer the call unless the destination extension is picked up.


Then you can encouer similar issues if the call is answered, for example auto-attendant, etc.


For this you have to configure some kind of supervisory disconnection, see;


http://cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00800ae2d1.shtml


Hope this helps, please rate post if it does!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (3 ratings)
Loading.
Correct Answer
paolo bevilacqua Mon, 10/01/2007 - 14:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Do you use connection plar under voice-port and if so do you have opx option of the command ? That makes the router no answer the call unless the destination extension is picked up.


Then you can encouer similar issues if the call is answered, for example auto-attendant, etc.


For this you have to configure some kind of supervisory disconnection, see;


http://cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00800ae2d1.shtml


Hope this helps, please rate post if it does!

martynch1 Tue, 10/02/2007 - 00:19
User Badges:

No joy I'm afraid. I have tried the following and any more suggestions would be greatly received


voice-port 0/1/0

translation-profile incoming 201

groundstart auto-tip

cptone GB

timing sup-disconnect 85

connection plar 1000

impedance complex5

description *** Voice Port ***

caller-id enable


voice-port 0/1/0

supervisory disconnect anytone

(omitted further output)


voice-port 0/1/0

no battery-reversal

(omitted further output)


Correct Answer
paolo bevilacqua Tue, 10/02/2007 - 12:22
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please enable opx in connection plar.


"disconnect anytone" is know to now work, you must enter the precise tone definitions unless your telco can enable ground start, or power denial.

martynch1 Wed, 10/03/2007 - 02:57
User Badges:

How do you work out the issues with AA, as you mentioned I'm not having issues with AA not hanging up


Thanks


Martyn

paolo bevilacqua Wed, 10/03/2007 - 11:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Ask telco if they can remove power when remote disconnects firsts. if they can as usually is the case, you must configure a custom tone detect as indicated in the document linked, that matches the tones used by telco. Use it with the "midcall" option.


Thanks for the nice rating and good luck!

paolo bevilacqua Wed, 10/03/2007 - 13:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

I menat, "if they cannot" in the post above, sorry.

fbellom Thu, 10/04/2007 - 00:06
User Badges:

Hi

I have the issue with AA from CUE, the FXO port stay off hook for a while, so if you can show me your config to see the AA it would be great.


here is the mine


voice class custom-cptone bolivar

dualtone disconnect

frequency 1450

cadence 500 500



voice-port 0/1/0

supervisory disconnect dualtone mid-call

supervisory custom-cptone bolivar

no battery-reversal

no vad

cptone VE

timeouts call-disconnect 5

timeouts wait-release 5

timing hookflash-out 100

timing guard-out 300

connection plar opx 105598 <---- AA RP

station-id name L1 XXXXXXXX

station-id number XXXXXXXX


If I change the DN from the RP to an IP Phone and this not answer the call everything work as expected


Thanks for any help you could give me

paolo bevilacqua Thu, 10/04/2007 - 03:16
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hola,


can you verify, that indeed the tone you configured is actually sent when remote party hang up?


Beside, the database at:

http://www.3amsystems.com/wireline/tone-search.htm?start=0&kCountry=187&kTone=&frequency=&cadence=

indicates 1440 Hz for "howler", not 1450.

When in doubt, you ca take a recording and post it here for frequency analysis.

fbellom Thu, 10/04/2007 - 07:35
User Badges:

Thanks for your answer and for the database, a awesome resource, I will do a try later at this day changing the frequency to 1440 in order to see what happen if I change the tone....


But how can I do to record this tonr from router, it is using the test voice port command? I do some sweep test with this command but I don?t know if this is enough.


Thanks in advanced


Freddy Bello



zhang.san Thu, 10/04/2007 - 04:26
User Badges:

Hi,Martyn

1) could you enable supervision disconnect

2) Pls reference BugID:CSCsi43340


I have same issue and open TAC case, TAC confirm it's a bug and open bug case.


Good lucky!

martynch1 Thu, 10/04/2007 - 08:41
User Badges:

Would that be supervision disconnect or supervision disconnect with anytone, Dualtone or Signal


Thanks for pointing me in the direction of the TAC case


Martyn

Actions

This Discussion