one way voice quality issue

Answered Question
Oct 1st, 2007

Hi forums,

What could be the cause of a one-way voice quality problem? we can hear the callers well, but the callers hear our voice choppy and breaking up.

We are using E1 links to MPLS cloud to the different sites. On our routers, we configure QOS, however, we are not sure if the remote router is doing the same.

Kind regards,

Pnigel

Correct Answer by allan.thomas about 9 years 2 months ago

Hi Paul, appreciate the update, it's good to hear that you were able to resolve the problem.

Its all part of the service, thank you for the rating.

Best Regards

Allan.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
AJAZ NAWAZ Mon, 10/01/2007 - 23:44

Do the sites have back-up links?

The symptoms described are consistent with asymetrical routing where the route back goes via the (normally) much slower back-up link such and ADSL.

So, you should perform traceroute from both ends. Make sure the source addr from this test, is the coming from the correct Voice Vlan interface. Make sure too that any return traffic comes from the source network, in our case this will be the IP phone subnet (or Voice Vlan interface). Do you get me?

Your CE or edge router tables should provide us with some useful information too.

let me know if you need any further clarification with regards to the investigation steps which I have outlined above.

regards

Ajaz

AJAZ NAWAZ Wed, 10/03/2007 - 22:47

Pringel,

Just interested to know if you indeed managed to get to the bottom of this?

cheers

Ajaz

paulnigel Thu, 10/04/2007 - 00:05

Hi Ajaz,

Thanks much for your advice. managed to get the other sides to do tracing from their site, below is the result, it looks like it is going out the right path.

trace to 142.14.250.8

1 <1 ms <1 ms <1 ms 142.22.202.252

2 <1 ms <1 ms <1 ms 142.22.192.5

3 30 ms 29 ms 29 ms 142.22.126.5

4 29 ms 29 ms 29 ms 142.29.56.1

5 95 ms 41 ms 57 ms 61.111.96.253

6 84 ms 88 ms 77 ms 199.220.90.181

7 78 ms 75 ms 74 ms 199.220.90.182

8 79 ms 92 ms 82 ms 142.20.252.2

9 82 ms 93 ms 89 ms 192.161.7.2

10 * * * Request timed out.

11 106 ms 88 ms 95 ms 142.14.250.8

trace to 142.22.255.9

1 2 ms <1 ms <1 ms 142.14.16.252

2 <1 ms <1 ms <1 ms 142.14.4.1

3 * * * Request timed out.

4 <1 ms <1 ms <1 ms 142.16.253.2

5 15 ms 20 ms 22 ms 192.161.7.1

6 16 ms 18 ms 7 ms 142.20.253.1

7 19 ms 20 ms 18 ms 199.220.90.181

8 54 ms 45 ms 45 ms 61.111.96.253

9 64 ms 58 ms 63 ms 61.111.96.254

10 * * * Request timed out.

11 86 ms 100 ms 98 ms 142.22.255.9

======================================

It looks like the trace to 142.14.250.8 has a lousier response time, could it be that the link is congested?

Thanks much,

Pnigel

paulnigel Mon, 11/05/2007 - 23:40

Hi forums,

I am really getting clueless to this. will policy route cause this type of problem?

thanks,

PN

AJAZ NAWAZ Mon, 11/05/2007 - 23:44

Paul

Yes policy routing could potentially be causing this if it results in asymetrical routing across a slower link.

Do you have a network diagram and configs from the relevant routing nodes?

Ajaz

paulnigel Mon, 11/05/2007 - 23:48

Hi Ajaz,

Can I send the config to you in private mails? once if this is solved, i will update the forum by clearing away the unnecessary?

Do you mind?

Thanks much,

PN

allan.thomas Tue, 11/06/2007 - 01:05

The fundamental questions are whether QoS is enabled within the MPLS?, and secondly if the answer to the previous is yes, then have the appropriate DSCP values been mapped accordingly?

If you are assure about the above, there are two options you can either trust the values in the event that there is at the remote end or reclassify accordingly if you are unsure.

I would capture the traffic at both ends in order to establish that the packets are marked correctly prior to MPLS then also on egress of the MPLS.

This will help you ascertain whether the DSCP/PHB for your voice traffic is correct at either end and where it is possibly being remarked.

If packets are remarked with 0 then you can be assured this traffic will be treated as best effort, and hence your quality issues if the link is congested.

Also remember to check your Call Admission Control and ensure you have not over subscribed the bandwidth to that in you Voice-Policy?

Regards

Allan.

HTH.

Pls rate helpful posts.

paulnigel Tue, 11/06/2007 - 01:19

Allan is giving a good piece of advice. ok, i will go through that and update again.

Thanks much,

paulnigel Thu, 12/06/2007 - 19:47

Hi Guys,

sorry for the delayed update.

Yes my problem is solved, it is due to the QOS setting at the MPLS provider end. After reverting to the normal settings. everything is smooth. Thanks everyone!

Correct Answer
allan.thomas Fri, 12/07/2007 - 00:52

Hi Paul, appreciate the update, it's good to hear that you were able to resolve the problem.

Its all part of the service, thank you for the rating.

Best Regards

Allan.

Actions

This Discussion