Rob Huffman Tue, 10/02/2007 - 04:41
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ana,


Have a look at setting up a directories;


Cisco Unified Communications Manager Express Configuring Directories


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00807e1325.html


Also have a look at this doc;


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a0080611961.html#wp1056637


You only need to configure a url if you don't want to use the local directory. Have a look;


The Cisco CME system automatically creates a local phone directory according to the telephone numbers that are assigned during ephone-dn configuration. Additional entries to the local Cisco CME directory can be made using the directory entry command. The additional numbers can be nonlocal numbers, such as telephone numbers of other Cisco CME systems used by the same corporation.



By default, the router automatically uses the local directory service. Provisioning the directory URL to select an external directory resource disables the Cisco CME local directory service. You can also disable the local directory by entering the no service local-directory command.



telephony-service


Example:

Router(config)# telephony-service

Enters telephony-service configuration mode.


Step 2

service local-directory


Example:

Router(config-telephony)# service local-directory

enables local directory service on IP phones.


Step 3

exit


Example:

Router(config-telephony)# exit


Hope this helps!

Rob


abartolomeu Tue, 10/02/2007 - 09:05
User Badges:

Hi!


When I first started configuring ephone I had the "url directories http://192.168.10.2/localdirectory". I have already denied that command and configured the "service local-directory" one. Since this last one is the default one it does not appear. Anyway in the router I can check that the service local-directory is enabled.


In the 7912 phones I still have at the network definitions the url directories even after resetting devices. No local directory appears.


What am I missing?


Thanks

Paolo Bevilacqua Tue, 10/02/2007 - 12:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Many FW versions for the 7912 do not correctly show all entries in directory menu.

Use 8.0(2) that is known to work.


Hope this helps, please rate post if it does!



Actions

This Discussion