HTTP keepalive with 302 response

Unanswered Question
Oct 2nd, 2007

TCP/80 keepalive works fine. With default HTTP keepalive the server showed down, so Ethereal traced and discovered response was 302 not 200. Set response code to 302, but still showed down. Any ideas?

service Doyle

protocol tcp

ip address

string doyle

keepalive frequency 10

keepalive retryperiod 10

keepalive maxfailure 2

port 80

keepalive uri "/uPortal/render.userLayoutRootNode.uP"

keepalive type http

keepalive http-rspcode 302


No. Time Source Destination Protocol Info

6 2.436764 HTTP HEAD /uPortal/render.userLayoutRootNode.uP HTTP/1.1

7 2.439238 HTTP HTTP/1.1 302 Moved Temporarily

8 2.599446 TCP 4341 > http [ACK] Seq=276 Ack=321 Win=8192 Len=0

HEAD /uPortal/render.userLayoutRoot Node.uP HTTP/1.0..

Connection: Keep-Alive..

User-Agent: Mozilla/4.06 [en](WinNT;I)..

Accept: image/gif,image/x-bitmap,image/jpeg, image/pjpeg,image/png, */*..

Accept-Language: en..

Accept-Charset: iso-8859-1 ,*,utf-8..


HTTP/1.1 302 Moved Temporarily..

Date: Tue,02-Oct 2007 09:31:43 GM

Server: Apache/2.0.52(Unix)mod_ssl/2.0.52 OpenSSL/0.9.7e mod_jk/1.2.8

uPortal-version: uPortal_rel-2-5-3..


Keep-Alive: timeout=15

Connection: Keep-Alive.

Content-Type: text/plain;charset=ISO-8859-1....

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Gilles Dufour Tue, 10/02/2007 - 23:56

could you do a 'show service Doyle' so we can see the keepalive reported error.

What software version ?



keithredding Thu, 10/04/2007 - 04:41

CSS11503# show version

Version: sg0810205 (

Flash (Locked):

Flash (Operational):


Licensed Cmd Set(s): Standard Feature Set

Secure Management

CSS11503# show service Doyle

Name: Doyle Index: 2

Type: Local State: Down

Rule ( x.x.126.139 TCP 80 )

Session Redundancy: Disabled

Redirect Domain:

Redirect String:

Keepalive: (HTTP-80:HEAD-302:/uPortal/render.userLayoutRootNode.uP 10 2 10


Keepalive Error: General failure

Keepalive Encryption: Disabled

Last Clearing of Stats Counters: 10/01/2007 14:06:50

Mtu: 1500 State Transitions: 51

Total Local Connections: 11181 Total Backup Connections: 0

Current Local Connections: 0 Current Backup Connections: 0

Total Connections: 11181 Max Connections: 65534

Total Reused Conns: 0

Weight: 1 Load: 255

Weight Reporting: None

String: doyle

b.petronio Mon, 01/18/2010 - 08:03

Hi all,

I'm getting the same problem ...

Im running a version on a CSS11501

and when i configure the command "keepalive http-rspcode 403", (which is what im getting from response) the service stays down and says "Keepalive Error: General failure".

Any ideas ?

Best Regards,

Bruno Petrónio

kgredding Mon, 01/18/2010 - 10:57

Hi Bruno,

Gave up and used scripted keepalives to match for a static title on the index page instead.

Then the developers wanted the CSS to lose a server if dependent services on several other servers went down, so get them to host an HTTP page with fields populated with "OK" from a query to each of the other servers, then had the script check for all the "OK"s.




This Discussion