Port duplex and speed settings

Unanswered Question
Oct 2nd, 2007


I have a 3845 router direct cabled to an ASA5400. The router was set for duplex auto and speed auto with the ASA set for duplex full and speed 100. With this, the router was showing the connection at 100/half. When I set the router to duplex full and speed 100 the interface went down and would not come back up.

If I set both devices to duplex auto and speed auto, then the router still only comes up to duplex half and speed 100.

I have the ASA set to duplex auto and speed auto, and the router to duplex full and speed 100. This now shows the router at 100/full as well as the ASA.

I thought you should always hard code both devices and not let them auto negotiate.

Why does the connection not work when both are hard coded?

Why does the connection not work the same when the ASA is hard coded and the router set to auto?

This was also true of the inside port of the ASA also going to another 3845 router.

Thanx for the help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jacobss914 Tue, 10/02/2007 - 14:12

I have found through hard times that what is taught is not always the best solution. I let the boxes tell me the solution that best fits the problem.

So here is my methodology, I start with auto-auto and watch the interface for errors. If I get errors I start on the device side that feeds into the core switch or router. Set it, watch errors again. If that does not come correct, set it on the core, and on the attaching device, and watch again. etc... 2 devices only 4 possible combos...

Now start port-chaneling and it can become even more fun.

Yes it can be a long task, you can speed it up by generating significant traffic to the device. Then once I think it is clean, I reset the counters on the interface and it run in the real world.

And yes you an spend a lot of time knocking out speed / duplex issues, but my network runs pretty clean. I also don't worry about client PCs unless I am seeing several 1000 errors with in a hour.

And here is the kicker it will change when somebody upgrades a NIC driver, or an IOS. Just part of the fun.

Hey you could have Nortels BPS2000 in which you had to hard code any device that 10mb or else it would not work. I am so glad they fixed that in a latter rev.. I am also glad I have weeded all them out of my network now.

Oh and a last note, if nothing fixes the issue don't forget about the cables and routing. Not routing in the sense of subnets, but physical layer routing.

Richard Burts Tue, 10/02/2007 - 14:52


Negotiation of duplex is dependent on negotiation of speed. If speed is hard coded on one or both sides and can not negotiate then duplex will not negotiate and any device configured with duplex auto will default to half if it can not negotiate duplex. I know some people who routinely will hard code most interfaces. In the early days this was pretty common practice because the negotiation was not so reliable. In today's hardware negotiation is pretty reliable and I believe that most people consider it best practice to have speed and duuplex set to auto, unless there is a particular reason not to or unless for some reason the devices are not negotiating correctly.




This Discussion