Router duplex and speed setting

Unanswered Question
Oct 2nd, 2007
User Badges:

Hello,


I have a 3845 router direct cabled to an ASA5400. The router was set for duplex auto and speed auto with the ASA set for duplex full and speed 100. With this, the router was showing the connection at 100/half. When I set the router to duplex full and speed 100 the interface went down and would not come back up.


If I set both devices to duplex auto and speed auto, then the router still only comes up to duplex half and speed 100.


I have the ASA set to duplex auto and speed auto, and the router to duplex full and speed 100. This now shows the router at 100/full as well as the ASA.


I thought you should always hard code both devices and not let them auto negotiate.


Why does the connection not work when both are hard coded?


Why does the connection not work the same when the ASA is hard coded and the router set to auto?


This was also true of the inside port of the ASA also going to another 3845 router.


Thanx for the help.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (3 ratings)
Loading.
scottmac Tue, 10/02/2007 - 14:49
User Badges:
  • Green, 3000 points or more

If your cable is in bad shape or improperly terminated, it can cause this kind of problem.


Make sure you are using a good quality commercially produced cable that is in good shape.


Good Shape means no kinks, twists, sharp bends, properly terminated (568a/b), proper strain relief, etc.


Good Luck


Scott


srosenthal Tue, 10/02/2007 - 15:19
User Badges:

I am using the yellow patch cord that Cisco shipped with the router. Not twisted or kinked. Besides, this is happening on two different routers connected to two different ports on the firewall.


Seth

JORGE RODRIGUEZ Tue, 10/02/2007 - 16:30
User Badges:
  • Green, 3000 points or more

Seth, the cisco cable that came with equipment is a stright through cat5, it is assumed router ethernet port will connect to switch, however, if you connect from router to router in case of asa it is a router you need cross-over cable, I believe this is why the duplex settings on either side don't synch up when hard coded.. try geting crossover cable and try dup settings .



http://www.cisco.com/en/US/docs/security/asa/asa72/hw/installation/guide/asaapc.html



srosenthal Wed, 10/03/2007 - 04:21
User Badges:

The Cisco 3845 router has Gigabit Ethernet ports, and Gig is auto cross.


Seth

Danilo Dy Wed, 10/03/2007 - 05:37
User Badges:
  • Blue, 1500 points or more

Hi,


Always use the old rule which is;

DTE to DTE is crossed

DCE to DCE is crossed

DTE to DCE is straight


Therefore use the right cable. Do not depend on the technology of auto-crossed/auto-straight (whatever), all these auto in the NIC is unreliable both old and new technology of auto.


Don't forget another rule which is;

Static connection should set to full-duplex/ 100Base (if available). i.e. Servers, Routers, Firewalls, etc.

Non-static connection should leave to auto/auto. i.e. Laptops, and any mobile devices


Regards,

Dandy

Actions

This Discussion