Incoming calls fail to voice gateway ( debug output attached)

Unanswered Question
Oct 3rd, 2007
User Badges:

im unable to receive incoming calls through my Cisco voice gateway 2821 .

However outgoing calls work perfectly,

debug output :

Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: pak_private_number: Invalid type/plan 0x0 0x0 may be overriden; sw-type 2 Oct 2 15: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x2 is 0x2

0x1, Calling num 26871398

Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: Applying typeplan for sw-type 0x2 is 0x0 0x0, Called num 26871301 Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: TX -> SETUP pd = 8 callref = 0x0082

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31Calling Party Number i = 0x2181, '26871398'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '26871301'

Plan:Unknown, Type:Unknown Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: RX <- SETUP_ACK pd = 8 callref = 0x8082

Channel ID i = 0xA9839F

Exclusive, Channel 31

Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x8082

Cause i = 0x82A2-No circuit/channel available

Progress Ind i = 0x8288 - In-band info or appropriate now available Oct 2 15:20:47: ISDN Se0/0/0:15 Q931: call_disc: PI received in disconnect; Postpone sending RELEASE for callid 0x8003 Oct 2 15:20:50: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8 callref =0x0082

Oct 2 15:20:50: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x8082

Oct 2 15:21:01: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x09F0

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Calling Party Numberi =0x0083,'99410610'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x81, '398'

Plan:ISDN, Type:Unknown

Oct 2 15:21:01: ISDN Se0/0/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x89F0

Channel ID i = 0xA9839F

Exclusive, Channel 31

Oct 2 15:21:01: ISDN Se0/0/0:15 Q931: TX -> DISCONNECT pd = 8 callref = 0x89F0

Cause i = 0x8091 - User busy

Oct 2 15:21:01: ISDN Se0/0/0:15 Q931: RX <- RELEASE pd = 8 callref = 0x09F0 Oct 2 15:21:01:

----------------

When i dial the DID from my GSM it says "User Busy".

VoiceGatewayconfig ...

-----------------------------------------

version 12.4


hostname VG-2821 !

card type e1 0 0

logging buffered 100000 debugging

resource policy

!

clock timezone GMT 4

network-clock-participate wic 0

ip subnet-zero

!!

ip cef

isdn switch-type primary-4ess

!

voice-card 0

dspfarm

dsp services dspfarm

!

controller E1 0/0/0

pri-group timeslots 1-31

!

interface GigabitEthernet0/0

description ** Connected to LAN **

ip address 172.16.1.40 255.255.0.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.16.1.40

!

interface Serial0/0/0:15

no ip address

isdn switch-type primary-4ess

isdn incoming-voice voice

!

interface Service-Engine1/0

ip unnumbered GigabitEthernet0/0

service-module ip address 172.16.1.42

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.2.1

voice-port 0/0/0:15

!

sccp local GigabitEthernet0/0

sccp ccm 172.16.1.41 identifier 1

sccp

!

dial-peer voice 5000 voip

destination-pattern 3..

session target ipv4:172.16.1.41

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 1000 pots

destination-pattern ....T

no digit-strip

direct-inward-dial

port 0/0/0:15

forward-digits all

!

gateway

timer receive-rtp 1200

-----------------------------------------

Cisco Call Manager : 4.2

i am also attaching the H.323 Gateway config , screen shots .


Thanks in Advance !!








Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
icabrera Wed, 10/03/2007 - 07:17
User Badges:
  • Silver, 250 points or more

Hi, only one thing, have you tried changing the channel selection order?, I can see at the debug that it's trying to get the channel 31, perhaps if you change it to get first the channel 0...


The command is:


interface Serial0/0/0:15

isdn bchan-number-order {ascending | descending}


Let me know if thereis any change.


Regards

CapitaServicedesk Wed, 10/03/2007 - 07:28
User Badges:

The debug indicates while placing a call from PSTN to any IP Extn, no appropriate Channels were available.


Also while placing a call to the DID No, all B channels were in use.


Can you make sure that your B Channels are in service.


Also this looks like a E1 Pri connection on a NM HDV2 module, did your provider specify the switchtype as "primary-4ess" , i suspect the problem lies with an incorrect switch-type.


Paste the output for


Show ISDN Service

Show ISDN Status



Magesh G. Wed, 10/03/2007 - 20:43
User Badges:


The Service uses Primary-4ess that is for sure !!


Also the provider says that my PRI Channels except channel 31 are getting blocked , due a " unknown potential being sent from my device ( voice gateway) ".


pls advice



Actions

This Discussion