Switch with 2 VLAN connect to one router port

Answered Question

Hi,

We have a switch with two different VLAN's 10 and 99 for management. They are connected to one F/E port on the router. Now we made on the switchport a trunk and on the router side divided the F/E port in 2 subinterfaces. But if on first subinterface we put Encapsulation dot1Q native 10 we don't get any traffic passing anymore but interfaces stay up. What could be the cause?

Currently subinterfaces are configured but only VLAN10 traffic is passed and interface on router has encap dot1Q native 1.

Thanks

Correct Answer by paul.matthews about 9 years 7 months ago

You appear to have native VLAN as 10 on the router and 1 on the switch - drop the native bit. If it insists on you having native somewhere, put it under th interface

int fas 0/0

enc dot1q 1 native


Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
paul.matthews Wed, 10/03/2007 - 06:02
User Badges:
  • Silver, 250 points or more

How have you got the switch port configured? I'll assume something like


int fas 0/3

switch

switch mode trunk

switch trunk enc dot1q

switch trunk allowed vlans 10,99


on the router you would need:


int fas 0/0

no ip address

int fas 0/0.10

enc dot1q 10

IP address


int fas 0/0.99

enc dot1q 99

IP address

Hi,


Switch:

interface FastEthernet1/0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10

switchport trunk allowed vlan 99

switchport mode trunk


Router:

interface FastEthernet0/0

description ATS DATA CHANNEL

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description ATS WIRED DATA VLAN

encapsulation dot1Q 10 native

ip address 10.101.40.1 255.255.255.0

ip access-group 160 in

ip helper-address 10.130.5.22

ip helper-address 10.30.5.215

no snmp trap link-status

!

interface FastEthernet0/0.2

description ATS MGMT VLAN

encapsulation dot1Q 99

ip address 10.101.45.1 255.255.255.128

no snmp trap link-status

Kevin Dorrell Wed, 10/03/2007 - 06:27
User Badges:
  • Green, 3000 points or more

You need the same native VLAN on both ends of the trunk. If you want VLAN 10 to be the native, then you need switchport trunk native vlan 10 on the switch;


But if I were you, I would leave the native as 1, and tag both 10 and 99. Just remove the "native" from F0/0.1.


Kevin Dorrell

Luxembourg


Correct Answer
paul.matthews Wed, 10/03/2007 - 06:28
User Badges:
  • Silver, 250 points or more

You appear to have native VLAN as 10 on the router and 1 on the switch - drop the native bit. If it insists on you having native somewhere, put it under th interface

int fas 0/0

enc dot1q 1 native


Paul

Actions

This Discussion