Restore error in CCM Disaster Recovery System

Unanswered Question
Oct 3rd, 2007
User Badges:

I managed two CCM PUB & SUB.

One CCM(PUB) occured to fail booting, CCM(SUB) was ok.

Now CCM(SUB) is working IPT service.

For recover this, I reinstall CCM(PUB).

I Backup CCM database & config with Disaster Recovery System from CCM(SUB).

And I restore DATA to new-installed CCM(PUB).

But restore failed with following log.


============== error log message =========

Log File: 2007-10-02-23-25-43_r_ccm1_ccm_ccmdb.log ==========

Server : CCM1

Feature : CCM

Component : CCMDB

Time Completed: 2007-10-02-23-34-37

Result Code : 1

Result String : ERROR

=====================================================

Dropping DB ccm0500v0000

Setting DB to multi user mode

Restoring DB...

CCMDB Restore failed, installdb failed



----> BEGIN Standard Output

Inside getdbnameFromodbc...

Line Matched:

Database=ccm0500v0000


csv file validation in progress...

Validate CSV complete.

Stopping DbMon

Service Manager is running

Cisco Database Layer Monitor[STOPPING]

Cisco Database Layer Monitor[STOPPING]

Component is not running

Cisco Database Layer Monitor[NOTRUNNIG]

Shutting down Replication -- replutil.py teardowndrf

Setting DB to single user mode


Dropping DB ccm0500v0000

Setting DB to multi user mode

Restoring DB...

Create database failed, check .../createdb.log

Failure 1

CCMDB Restore failed, installdb failed, error:

1

Restore failed.


----> END Standard Output



----> BEGIN Standard Error

+ '[' 3 -lt 3 ']'

+ sudo -u root /usr/local/cm/bin/do_db_restore.sh /common/drf/restore.log

/common/drf/status.txt /common/drf/2007-10-


02-21-55-50/ccm1_ccm_ccmdb.tar

command failed -- Enterprise Replication not active (62)


Database selected.



425: Database is currently opened by another user.


107: ISAM error: record is locked.

Error in line 1

Near character position 26


Database closed.


+ res=1

+ '[' 1 == 0 ']'

+ echo 'Restore failed.'

+ exit 1


----> END Standard Error


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchandak Wed, 10/03/2007 - 08:24
User Badges:
  • Gold, 750 points or more

You cannot take a Backup from the Subscriber and install it on the Publisher. Backup should always be taken from the Publisher and then restored.


Incase you dont have a valid backup of the Publisher, I dont think you can do a DRS Restore.

hut982010 Sun, 08/01/2010 - 20:54
User Badges:

Hi Drazik,


I also have the same error. I only turn on the  Publisher, I stop Cisco Database Layer Monitor, but I still get the error.


If you have resolved the error, please help me to fix it.


Thanks you so much,


Hut982010

Actions

This Discussion