Question About Configuration for AT&T T1 with network

Answered Question
Oct 3rd, 2007
User Badges:

Hi Guys,

I have a router with a VWIC2-1MFT-T1/E1 card that we will be using for a internet data connection with AT&T. I have not done this before so I wanted to ask regarding my setup and what I need to change to get the AT&T connection up.


Currently I have my FA0/0 connection with an IP address of 10.1.1.x going to the internal LAN.


AT&T provided me with this information about the internet connection:


AT&T Circuit ID: .DHEC.XXX

Channels: 1-24

Customer Serial IP Address: 12.87.Y.Y

AT&T Router IP Address: 12.87.X.X

Subnet Mask: 255.255.X.X


From my undertstanding, I have to specify the 12.87.Y.Y address on my T1 Serial interface and my default gateway will have to go to the AT&T Router IP Address.


What confuses me is that AT&T also provided the LAN block information:


LAN Information:

LAN Block: 12.43.Y.Y/25

LAN/Ethernet/Gateway IP Address: 12.43.X.X

Broad Cast IP Address: 12.43.X.X

Subnet Mask: 255.255.X.X


Where do I specify this information, as I am currently already using the other IP given, and my internal network is of the 10.1.1.x range (which will be NATed).


Thank you for any recommendations!

Correct Answer by sundar.palaniappan about 9 years 5 months ago

They must have given you the LAN public address block, gateway info etc. thinking that you would be configuring the public address on the LAN interface. Since you are already using a private address range for the LAN you probably don't want to go through the hassle of renumbering IP for the LAN hosts.


The best thing to do here is to take the whole public block of 12.43.Y.Y/25 they gave you and NAT all the inside addresses to use the address from this public pool.


Your configuration would look something like this.


int e0

ip address 10.1.1.x/24

ip address inside


int s0/0

ip address 12.87.Y.Y/30

ip address outside


ip route 0.0.0.0 0.0.0.0


ip nat pool <12.43.1.1> <12.43.1.127> netmask 255.255.255.128 --> Use the starting and ending address of the LAN block given to you here.

ip nat inside source list 1 pool


access-list 1 permit 10.1.1.0


HTH


Sundar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Richard Burts Wed, 10/03/2007 - 08:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Yes you would configure 12.87.Y.Y as the IP on your router serial interface. And assuming that you will be configuring a static default route then the next hop specified in the default route would be 12.87.X.X.


If you want to continue using 10.1.1.x as your internal network address space then you would take the 12.43.Y.Y/25 which AT&T gave you and you would use that as the pool from which to NAT addresses.


HTH


Rick

tomtom001 Thu, 10/04/2007 - 10:36
User Badges:

Thank you for the reply Rick.


Quick question regarding the 12.43.Y.Y/25 address information. I understand that I will use that LAN block for the NAT pool, however I'm a bit confused as to what to do with the LAN/Ethernet/Gateway IP Address 12.43.X.X that they provided. Since I already have a static route pointing to the next hop at 12.87.X.X, what do I use this second Gateway IP address for.


Once again, thank you for the help. It has been very educational for a newbie like me.

cisconoobie Thu, 10/04/2007 - 10:45
User Badges:

I believe that would be your Inside Interface on the Router. You would point your Inside Public hosts to this IP. As for your 10.x.x.x network, thats private and has to be natted either on the router or firewall.

Correct Answer
sundar.palaniappan Thu, 10/04/2007 - 11:16
User Badges:
  • Green, 3000 points or more

They must have given you the LAN public address block, gateway info etc. thinking that you would be configuring the public address on the LAN interface. Since you are already using a private address range for the LAN you probably don't want to go through the hassle of renumbering IP for the LAN hosts.


The best thing to do here is to take the whole public block of 12.43.Y.Y/25 they gave you and NAT all the inside addresses to use the address from this public pool.


Your configuration would look something like this.


int e0

ip address 10.1.1.x/24

ip address inside


int s0/0

ip address 12.87.Y.Y/30

ip address outside


ip route 0.0.0.0 0.0.0.0


ip nat pool <12.43.1.1> <12.43.1.127> netmask 255.255.255.128 --> Use the starting and ending address of the LAN block given to you here.

ip nat inside source list 1 pool


access-list 1 permit 10.1.1.0


HTH


Sundar

tomtom001 Thu, 10/04/2007 - 13:21
User Badges:

Perfect. Thank all you guys for clearing up my confusion. Appreciate the help!

Actions

This Discussion