Can't find nbar option on Cisco 800 series router

Unanswered Question
Oct 9th, 2007
User Badges:

I want to enable nabr on my Cisco 837 (then 877) routers to use with Netflow. I don't see the nbar option.

This link says IOS 12.3 T http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a0080455985.html


here is my Sh version.


Router>sh ver

Cisco IOS Software, C837 Software (C837-K9O3Y6-M), Version 12.4(5b), RELEASE SOF TWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Wed 19-Apr-06 05:59 by ssearch


ROM: System Bootstrap, Version 12.2(11r)YV6, RELEASE SOFTWARE (fc1)


f3rryun1t2 uptime is 21 hours, 57 minutes

System returned to ROM by power-on

System restarted at 11:34:22 UTC Mon Oct 8 2007

System image file is "flash:c837-k9o3y6-mz.124-5b.bin"



This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

[email protected].


Cisco C837 (MPC857DSL) processor (revision 0x600) with 58983K/6553K bytes of mem ory.

Processor board ID FCZ111711KJ (3514411306), with hardware revision 5E5D

CPU rev number 7

2 Ethernet interfaces

4 FastEthernet interfaces

1 ATM interface

128K bytes of NVRAM.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)


Configuration register is 0x2102


Router>


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
whiteford Tue, 10/09/2007 - 02:22
User Badges:

Thing is isn't my one a later version 12.4 as the required version is 12.3T

paolo bevilacqua Tue, 10/09/2007 - 02:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

So you will need to purchase a support contract (aka smartnet) for the router, available from any reputable cisco partner or reseller, this will eventually enable you to download images on CCO.

whiteford Tue, 10/09/2007 - 02:55
User Badges:

Think I'm confusing us here sorry. I can download any image as I have a smartnet contract.


it looks like my version does support nbar from that link you sent, but don't appear on the router.


Just configured the Cisco 837 router and the Netflow server receives nothing (assuming I have configured the Netflow server correctly):


It seems the extended ping and trace on port 9996 worked.


From the beginning on the Cisco 837 I have added:

configure terminal

router(config)#interface Ethernet 0

router(config-if)#ip route-cache flow

router(config-if)#exit

router(config)#ip flow-export destination 192.168.9.101 9996

router(config)#ip flow-export source Ethernet 0

router(config)#ip flow-export version 5

router(config)#ip flow-cache timeout active 1

router(config)#ip flow-cache timeout inactive 15

routerconfig)#snmp-server ifindex persist


Still no data on the Netflow site. Says flow's received 5 though.


sh ip flow export:


Flow export v5 is enabled for main cache

Exporting flows to 192.168.9.101 (9996)

Exporting using source interface Ethernet0

Version 5 flow records

9839 flows exported in 1883 udp datagrams

0 flows failed due to lack of export packet

1 export packets were sent up to process level

0 export packets were dropped due to no fib

0 export packets were dropped due to adjacency issues

0 export packets were dropped due to fragmentation failures

0 export packets were dropped due to encapsulation fixup failures

paolo bevilacqua Tue, 10/09/2007 - 04:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You may be running into a bug. Upgrade to latest 12.4 and if the problem persist log a case with the TAC as entitled by the support contract.


Before doing that I would confirm with a sniffer that the router is actually not transmitting UDP/netflow packets. If it is, problem is on the collector/analyzer platform.

whiteford Tue, 10/09/2007 - 04:06
User Badges:

is there an extended command to ping the server using UDP 9996?

Actions

This Discussion