cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1070
Views
0
Helpful
9
Replies

QOS over MPLS

wbarren
Level 1
Level 1

We are setting up our first site to do VOIP over our MPLS network. We have a CME in our remote site and CCM in our head site. Our service provider has us set up with EF Que for the voice priority EF QUE. On the remote side we have a 2811 which I have setup the following and applied to the serial interface:

class-map match-all L3-to-L2_VoIP-Cntrl

match ip dscp af31

match ip dscp cs3

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp ef

policy-map Voice_wan

class L3-to-L2_VoIP-RTP

bandwidth percent 5

class L3-to-L2_VoIP-Cntrl

priority percent 25

On the head end side we have a Cisco 3845 which I have setup and applied on the serial interface:

class-map match-all L3-to-L2_VoIP-RTP

match ip dscp ef

class-map match-all L3-to-L2_VOIP-Cntrl

match ip dscp af31

match ip dscp cs3

policy-map Voice_wan

class L3-to-L2_VOIP-Cntrl

priority percent 2

class L3-to-L2_VoIP-RTP

bandwidth percent 5

class class-default

fair-queue

We also have a Catalyst 4500 which has the following setup:

qos dbl

qos map dscp 24 25 26 27 28 29 30 31 to tx-queue 4

qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4

qos map cos 3 to dscp 26

qos map cos 5 to dscp 46

qos

interface GigabitEthernet

description link to Router

no switchport

ip address x.x.x.x x.x.x.x.

speed 1000

duplex full

qos trust dscp

auto qos voip trust

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

service-policy output autoqos-voip-policy

The interface on the 4500 above connects to the 3845. I have a few questions, first on the 3845 on the Ethernet interface do I need to set a trust from the 4500? If so can anyone explain how to do this? Third is the QOS I setup so far correct? Thanks all.

9 Replies 9

Phillip Hichens
Level 1
Level 1

Hi

The 3800 will accept the the markings from the 4500 with your configuration.

Looks like you got your LLQ swapped around (Priority/Bandwidth statements in policy-maps), remember the voice (RTP) is more important than the signalling (Cntrl).

If you are not trusting the CoS markings from your IP phones you should remark the traffic on your Switch or router on udp ports 16384 to 32767.

Other than that your QoS will work.

Regards

Phillip

bvsnarayana03
Level 5
Level 5

You may have to use "mls qos trust" on interfaces to which IP phones are connected.

Also change the bandwidth to Priority for RTP traffic in the policy-maps. RTP is the actual voice traffic & needs priority queuing.

Another method of QoS if 1 is not sure of the markings, turn-on "ip nbar protocol-discovery" on the router & then match clas-maps with protocols rather than dscp markings.

Mohamed Sobair
Level 7
Level 7

Hi,

You dont need trust between (2) laye-3 interfaces, since your SW-interface is connected to a layer-3 router interface with policer applied.

The Only point is to make sure ur IP-Phones are trusted in the Sw ports, and you override ur PC's Data traffic associated with the IP-Phones to have diffrent marking in order to avoid it to be priotrized , here is example:

int e0/1

mls qos trust cos

switchport mode access

switchport voice vlan x

switchport access vlan y

switchport priority extend cos 2

this will override all PC's traffic with a COS of 2 and leaves Voice with its default CoS 5.

Another Method if u have Switches between the L3 routers, and you have the Same DSCP values and needs to be configured for future, you can configure the SW to forward any DSCP value it receives rather than doing L3-to-L2 mapping and Vice vers.

HTH

Mohamed Sobair

This is what I have on my phone ports on the switch.

switchport access vlan xx

switchport mode access

switchport voice vlan xx

qos trust device cisco-phone

qos trust cos

auto qos voip cisco-phone

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

spanning-tree portfast

spanning-tree bpduguard enable

service-policy output autoqos-voip-policy

Hi,

Looks OK,

HTH

Mohamed Sobair

I have make all the changes and I am still getting choppy calls across the wan. Is there a way I can debug that packets and ensure they are being marked correctly?

I would use Wireshark.

Also make sure you have enough bandwith, correct codecs for the WAN (G729) and CAC configured on the CMs.

What is your round-trip delay time when you ping from one voice source to destination? Choppiness may be due to latency in the circuit as well.

Mohamed Sobair
Level 7
Level 7

Hi,

You might use the EXEC mode command bellow to check QoS values at specific interface:

# show mls qos int x

HTH

Mohamed Sobair

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: