IPCCX 4.5: unable to make changes

Unanswered Question
Oct 10th, 2007

Hello,

We have IPCCX 4.5 system, but we are unable to make changes. We can't remove applications, scripts, prompts etc.

The error is:

com.cisco.app.ApplicationException: can not acquire ClusterMutex

com.cisco.config.ConfigException: UnmarshalException

javax.xml.bind.UnmarshalException: Document root element is missing. - with linked exception: [org.xml.sax.SAXParseException: Document root element is missing.]

Any suggestions?

Thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
matt.wilkerson Tue, 10/16/2007 - 04:46

Any luck on this one? I'm getting the same problem. I've seen it with pre 4.5 before when LDAP was used but not without LDAP in 4.5.

thanks.

agster.bt Wed, 01/30/2008 - 08:15

Same here.... used the fix with CM 4... but can't use it with CM 5....

Anyone had any joy?

matt.wilkerson Wed, 01/30/2008 - 09:40

Hi there,

Actually all the keys are located in a directory on the Linux paired versions. If you search for the same key on the hard drive, you should find it (can't remember the directory since I'm not in my office) but you can re-name that same key. (add .old as extension for example)

The IPCC should re-create the key properly after that lock is no longer there.

Let me know how that turns out for you and I can find specifics if necessary.

agster.bt Thu, 01/31/2008 - 01:29

Hi Matt,

Thanks for the response, yes if you could supply the specifics that would be excellent, I don't proclaim to be a Linux expert or even close to one so all information you could provide would be greatly accepted. I do have guys in the office who are more at home with it so a combination of the two should get us back on track with this customer.

Thanks again

Andrew

matt.wilkerson Thu, 01/31/2008 - 07:09

Hi Andrew,

I was able to dig up exactly what we did. Hopefully this will do the trick. This is on the IPCC server itself since there is no DC Directory on Callmanager in a Linux environment.

***

This error is caused by a corrupted lock file in

c:\program files\wfavvid\ClusterData\

name>\com.cisco.crs.cluster.config.LockConfig directory on the CRS server.

Rename all files in this directory to .old and make an update in Appadmin.

This generated new files and it worked properly.

****

matt

agster.bt Thu, 01/31/2008 - 10:43

Matt,

You are a legend! You won't believe how many engineers were blank to this issue.

Worked perfectly...

Thanks alot.

Andrew

Actions

This Discussion