STP Question

Unanswered Question
Oct 11th, 2007
User Badges:

Core1--L1--Core 2

| |

|----Sw1 ---|

If i have the above diagram which includes 2 cores switches and edge switch.

L1 is not trunk port .It is access link in vlan 10.

Sw1 is connected to both of the cores by trunk links .

The Vlan of the Sw1 is 20.

The Core1 is the active for HSRP.

Do i need to force the core 1 to be the root for vlan 20 ?

I think the STP is n ot an issue here can anyone confirm that pls?

Thanks,


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Kevin Dorrell Thu, 10/11/2007 - 04:57
User Badges:
  • Green, 3000 points or more

No, you do not have to force the root. In any case as far as VLAN 20 is concerned, there is no loop. Futhermore, Spanning Tree will always give you full connectivity.


The strange thing about you architecture here is that the core switches will be talking HSRP on VLAN 20 through your edge switch.


Kevin Dorrell

Luxembourg



welcomeccie Thu, 10/11/2007 - 06:46
User Badges:

Kevin,

You are right But do you think that there will be a problem in the redundancy process if the 2 cores will be talking HSRP on vlan 20.

Suppose that there are many edge switches each edge has its own vlan an connected to the 2 cores by the same way.

Regards,

CCIE

Kevin Dorrell Thu, 10/11/2007 - 06:56
User Badges:
  • Green, 3000 points or more

There could well be an issue there. It is difficult to imagine how the redundancy would work. If the access switch was the only one carrying VLAN 30, and it lost its link to one of the core switches, then both core switches would become HSRP active because they would lose sight of each other. I guess the access switch would just use the active router that it still has a link to. But the other VLANs might be using the other core switch as router, and those would not be able to reach VLAN 20.


All in all, I think a better architecture would be to tie the two core switches together with a good solid trunk carrying all the VLANs. Which is the "normal" architecture.


Kevin Dorrell

Luxembourg


welcomeccie Tue, 10/16/2007 - 01:51
User Badges:

Hi Kevin,

But i think the connectivity between the vlans will be ok if we use Dynamic routing protocol between the 2 cores.

Regards,

CCIE

welcomeccie Tue, 11/13/2007 - 14:58
User Badges:

Can anyone confirm that the STP will not work on L1 for any vlan execpt vlan 10?

Francois Tallet Tue, 11/13/2007 - 17:57
User Badges:
  • Gold, 750 points or more

If you are running a PVST mode (PVST or Rapid-PVST) you can forget about STP. You can probably configure portfast on those ports if they are the only one on their respective vlans. If you are running MST, you're asking for trouble by using access links (I doubt you do so I won't elaborate;-)

As Kevin already mentioned, you might have a L3 issue if say, the uplink between SW1 and core1 goes down. You have to be sure that the interface vlan 20 goes down on core1 so that core1 does not advertise a route to the subnet any more and does not black hole your traffic. I think you are aware of that. There is a feature on Cisco switches that brings down a vlan interface if there is no port forwarding for the vlan on the switch... So you should be ok as long as the only link configured for vlan 20 on core 1 is the downlink to sw1. Because of this requirement, I'm wondering why you want to use switchports. Just configure all your ports as L3 interfaces instead of switchports and you can safely forget about STP.

Regards,

Francois

welcomeccie Tue, 11/20/2007 - 02:37
User Badges:

Hi ftallet,

You said that There is a feature on Cisco switches that brings down a vlan interface if there is no port forwarding for the vlan on the switch.

Can you pls tell me about that feature?

Francois Tallet Tue, 11/20/2007 - 08:26
User Badges:
  • Gold, 750 points or more

Hi,

The feature is called "autostate". This is enabled by default and I don't think there is a CLI to disable it (there might be some engineering commands though). If you have no port forwarding in a given vlan, the vlan interface should be brought down. If you don't see this behavior, this is a bug.

Regards,

Francois

Actions

This Discussion