Slow to No Performance CISCO 1841 over T1 Line

Unanswered Question
Oct 11th, 2007
User Badges:

Hello,


I have setup a CISCO 1841 with the following configuration and experiencing extremely slow connections to websites over our T1 link to the Internet. I just configured this router and was wondering if anyone could find anything in my configuration that would provide me with an idea of what is causing this problem. Version and Config are attached.


Any help at this point would be greatly appreciated as I have been over this many times even switching routers to try and solve the issue to no avail.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lgijssel Thu, 10/11/2007 - 10:20
User Badges:
  • Red, 2250 points or more

Can you please repost the config? The current one does not have CR/LF which makes it almost unreadable.

Richard Burts Thu, 10/11/2007 - 11:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Chuck


The first thing that I notice is that you have turned off CEF on the serial interface:

no ip route-cache cef

I am not sure why this was done but it forces the router to process switch which imposes quite a processing burden on the CPU. I suggest that you turn CEF on and let us know if performance improves.


HTH


Rick

chuckk139 Thu, 10/11/2007 - 11:22
User Badges:

I have tried earlier enabling CEF. The config posted was a slightly earlier version without a few of my changes attempting to resolve the situation. It really seemed to make no difference.

chuckk139 Thu, 10/11/2007 - 11:55
User Badges:

This particular router is not currently connected to the CSU/DSU as we switched back to a different router with a different config for the moment to provide service for users. I did see several input errors on both the F0/0 and S0/0/0 interfaces. I tried changing the duplex on the F0/0 from auto to both full and half. Neither improved the situation.

chuckk139 Thu, 10/11/2007 - 15:43
User Badges:

Could only run it for a few minutes as was disrupting the access of the 3rd shift. Show int S0/0/0 is attached.



Attachment: 
chuckk139 Thu, 10/11/2007 - 20:07
User Badges:

This was the config between the two routers

Config on Current Router CISCO 1841


interface Serial0/0/0

description connected to Internet

ip address X.X.X.186 255.255.255.252

ip access-group 101 in

ip nat outside

ip virtual-reassembly

ip route-cache flow

no ip mroute-cache


Config on Previous Router CISCO 1721


interface Serial0

description connected to the Internet

ip address X.X.X.186 255.255.255.252

ip access-group 101 in

ip nat outside

ip inspect outbound out

no ip route-cache

no ip mroute-cache

no cdp enable


lgijssel Thu, 10/11/2007 - 11:19
User Badges:
  • Red, 2250 points or more

You said the line was a T1? Did you perhaps mean a WIC-1T?

Although the router normally should not be generating the clock, I noticed the clock-rate entry on the serial line which is unusual unless you are using a DCE-cable.

If the line is a T1 and you are generating the clock, it's set incorrectly. A T1 only does about 1,5Mb, not 2Mb. Decrease the clock rate and check what happens.

You may have a faulty cable as well, I consider this a possibility because you do not see a clockrate on a DTE which is clocked from the network.


The other thing is acl 101, it's just too long to be OK. You may feel uneasy about removing it completely but for a short test, it will do no harm.


regards,

Leo

chuckk139 Thu, 10/11/2007 - 11:52
User Badges:

The cable should be good. A router configured differently hooked to the same cable works perfectly fine. Just it's using the CISCO IP Basic IOS, both are 1841s. I have made some changes suggested and am still experiencing the same issues. Attached is the latest version of the config.


I know the access-list is getting a bit lengthy, but I had the same list running on a CISCO 1721 Router for at least a year and never a hickup.



Attachment: 
nathancielieska Thu, 10/11/2007 - 12:50
User Badges:

input errors on a serial interface are especially bad, i would have your carrier start testing to the CSU/DSU right away. Do you own the CSU/DSU? Can it being going on you?


First step if seeing input errors on your serial is call the carrier though.

chuckk139 Thu, 10/11/2007 - 12:59
User Badges:

I have so far they haven't gotten back to me. The reason I don't believe it is their issues is that I use the same router with a different configuration it works fine. Basically if I use the inspect commands in my config and the specific access-list in the config my connection speed goes down to barely usable.

chuckk139 Fri, 10/12/2007 - 06:19
User Badges:

Spoke with the service provider, the can find no problems on their end. In addition I have noticed that as soon as I enable the ACL 101 that is when the problem begins. However I can find no difference between the ACL that I am now running and one I was running on 1721 I was running up to monday which had the flash memory fail on it. I am reposting the current config on 1841.



Attachment: 
chuckk139 Fri, 10/12/2007 - 12:21
User Badges:

Just an additional clarification. When I mean I enable ACL 101 I mean if I just so much as issue the command:


access-list 101 permit tcp any host X.X.X.33 eq 1494


immediately the Internet becomes unusable. No deny command nothing. I have tried this config on two different routers 1841 routers. I really am at a loss on this one.

Actions

This Discussion