easy dial-peer question

Answered Question
Oct 12th, 2007

Hi. I have two dial peers conflicting by the looks of it. Dial-peer 53 works fine.

!

dial-peer voice 53 pots

description ** Outgoing national landline / mobiles **

destination-pattern 90..........

port 0/1/0

forward-digits 11

no sip-register

!

A colleague tried to call a customer in Ireland (now a national call) and obviously didnt connect becasue I didnt have an international dial peer. OK.. so I write Dial-peer 54...

!

dial-peer voice 54 pots

description ** Outbound International Call **

destination-pattern 900...........

port 0/1/0

forward-digits 13

no sip-register

!

Yes, you guessed it.. My international call to 9 00 00 00 00 00 000 meets my dial-peer 53 rather than hitting dial-peer 54.

Is it just because im not using preferences or is my rule just incorrect?

Thanks

I have this problem too.
0 votes
Correct Answer by nomiel about 9 years 3 months ago

Hi.

As I understand, second 0 only occurs during international call, so you can write in dial-peer 53 destination-pattern 90[1-9].........

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
nomiel Fri, 10/12/2007 - 02:29

Hi.

As I understand, second 0 only occurs during international call, so you can write in dial-peer 53 destination-pattern 90[1-9].........

davieshuw Fri, 10/12/2007 - 02:40

hi cheers for the response.. I now have..

!

dial-peer voice 54 pots

description ** Outbound International Call **

destination-pattern 90[1-9]...........

port 0/1/0

forward-digits 13

no sip-register

!

but still the same issue. The last 2 digits of my international number are being chopped off.

AJAZ NAWAZ Fri, 10/12/2007 - 02:39

hmm...

look at this:

----------------------------------------------

<http://www.cisco.com/warp/public/788/AVVID/backup_cm.html>

Note: When you set the preference order, the lower the preference number, the higher the priority. The highest priority is given to the dial peer with preference order 0 and it is the default value. You can have a preference value between 0 to 10.

Further configuration procedures are:

1. Set up the dial peer that points to the primary Cisco CallManager server with a preference of 1.

Note: In this case, the preference command takes effect because the destination patterns under the two dial peers are the same (otherwise "longest match" overrides it).

---------------------------------------------

I want to take a further look at this. Be right back.

Ajaz

davieshuw Fri, 10/12/2007 - 02:49

Right. I now have:

!

dial-peer voice 53 pots

description ** Outgoing national landline / mobiles **

preference 10

destination-pattern 90..........

port 0/1/0

forward-digits 11

no sip-register

!

and

!

dial-peer voice 54 pots

description ** Outbound International Call **

preference 1

destination-pattern 90[1-9]...........

port 0/1/0

forward-digits 13

no sip-register

!

It still must be meeting dial-peer 53 because it still chops off the remaining 2 digits

AJAZ NAWAZ Fri, 10/12/2007 - 02:51

Read towards the end of my previous post!.

Longest match rule overrides dial-peer preference configuration.

Ajaz

davieshuw Fri, 10/12/2007 - 02:55

Yes, it states that the preferences are overidden if the destination patterns are the same; mine are not

AJAZ NAWAZ Fri, 10/12/2007 - 03:01

Correct so which one of the patterns provides for the best match?, or are we saying that just one of them matches the dialed destination or are we talking in terms of choice between the two?

Ajaz

AJAZ NAWAZ Fri, 10/12/2007 - 03:04

You are dialing a total of 14digits. The first dial peer (53) has the longest match pattern for this. In fact it's the only match since the second dial-peer (54) only has 12digits so it will not match period!

hth,

Ajaz

davieshuw Fri, 10/12/2007 - 03:10

90[1-9]........... is only 12 digits then? because one of the zeros isnt forwarded in an international call?

AJAZ NAWAZ Fri, 10/12/2007 - 03:15

I make that 14digits but [1-9] means any number from 1-9. What is the number you are dialling?

Ajaz

AJAZ NAWAZ Fri, 10/12/2007 - 03:27

That's 13digits. So neither 12 nor 14.

NOTE - forward-digits (after outbound dial peer match)

try this - 90[1-9]..........

Ajaz

nomiel Fri, 10/12/2007 - 03:40

you don't need to change 54 dial-peer, as it was correct in the beginning, just change dial-peer 53, as I wrote earlier

davieshuw Fri, 10/12/2007 - 03:51

That'll teach me to read correctly wont it!!

Thanks chaps

Cheers, its working

AJAZ NAWAZ Fri, 10/12/2007 - 03:53

pleasure - hope you you have a great w/end especially after that!

Ajaz ; )

Actions

This Discussion