IVR DTMF issues

Answered Question
Oct 14th, 2007
User Badges:

Hi we are running c2600-ipvoice-mz.124-7f.bin on a 2651XM. This is a recent upgrade and it appears to have caused problems with IVR's being unable to recognise DTMF tones . Downgrading to the original c2600-is-mz.123-18.bin appears to have resolved the problem.

DTMF relay is configured on the gateways.


Further details arte unavavailble at present as the customer is slow to update us. I am unable to fins a bug specfific to the new code that would cause this. It does not appear to be config related. Any one else had similar issues ?


Thanks,


Pete

Correct Answer by joepapesh about 9 years 7 months ago

Pete,


I have had a similar issue before, and it was caused by the bug listed below. The problem for me was actually caused by the DSPware, so TAC offered me the following options...


CMM - Downgrade the code (we were trying 12.4(7d))


2811 - Downgrade the code, or downgrade just the DSPware.


We decided to downgrade the code, and have happily settled on 12.4(7c). We didn't want our DSPware out of sync with the main IOS release (because we figured it would only cause confusion). I am not sure what prompted the upgrade, but unless there was a specific feature you probably don't want to go higher than 12.4(7c).


http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCsi76529&Submit=Search


I hope this helps,

--Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Anonymous (not verified) Fri, 10/19/2007 - 09:20
User Badges:

Do you find any errors while doing debug using sh controllers command?

peter.campion Mon, 10/22/2007 - 13:28
User Badges:

Hi,


WE did not attempt any troubleshooting - customer demanded immediate back out.


Thanks,


Pete

Correct Answer
joepapesh Fri, 10/19/2007 - 11:17
User Badges:

Pete,


I have had a similar issue before, and it was caused by the bug listed below. The problem for me was actually caused by the DSPware, so TAC offered me the following options...


CMM - Downgrade the code (we were trying 12.4(7d))


2811 - Downgrade the code, or downgrade just the DSPware.


We decided to downgrade the code, and have happily settled on 12.4(7c). We didn't want our DSPware out of sync with the main IOS release (because we figured it would only cause confusion). I am not sure what prompted the upgrade, but unless there was a specific feature you probably don't want to go higher than 12.4(7c).


http://www.cisco.com/cgi-bin/Support/Bugtool/onebug.pl?bugid=CSCsi76529&Submit=Search


I hope this helps,

--Joe

peter.campion Mon, 10/22/2007 - 13:27
User Badges:

Hi Joe,


This sounds likely......but we are running DSPWARE 4.1.41. So unless the bug is affecting a wider range of Firmware than that specified we should be OK.


Thanks, Pete

peter.campion Mon, 10/22/2007 - 13:34
User Badges:

Hi Joe,


Please ignore previous reply ..... I goofed big time !!! Just checked gateway running IOS in question..... and its running 4.4.24 as you would expect as its imbedded in the IOS....


I think this is it - I now need to test.....


Cheers,


Pete

Actions

This Discussion