RTP stream goes via CME when using 3rd party SIP phones

Unanswered Question
Oct 15th, 2007

I am running CME 4.1 on 2811 (c2800nm-spservicesk9-mz.124-11.XJ.bin). I have configured SCCP 7940 phone and x-lite SIP phone. When making a call between SIP to SIP, SIP to SCCP or SCCP to SIP, The RTP stream goes via CME, not dirrectly between phones. Have tried command "media flow-around" under "voice register global" and "voice register pool x" but still not working.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Mon, 10/15/2007 - 05:29


one thing is that cisco does not officially supports third-party sip phones, so it's good already that it work no matter the media path.

Anyway have you tried with cisco SIP phones? It is quite possible that the media goes cme as well.

glenn.hunter Mon, 10/15/2007 - 05:57

Thanks, I will set this up in the lab and get a 7905 SIP phone working and see if this has the same problem. here is my config. note: I have removed "media flow-around" command


voice service voip

allow-connections sip to sip

signaling forward unconditional


registrar server


voice class codec 1

codec preference 1 g711ulaw


voice register global

mode cme

source-address port 5060

max-dn 3

max-pool 3

authenticate register

authenticate realm nnn.se


voice register dn 1

number 601


voice register pool 1

id mac 0011.2586.FBC2

type ATA

number 1 dn 1

voice-class codec 1

username 601 password cisco


dial-peer voice 601 voip

destination-pattern 601

session protocol sipv2

session target ipv4:

dtmf-relay rtp-nte

codec g711ulaw


glenn.hunter Wed, 10/17/2007 - 02:14

I have setup a test in a lab environment. Enabled the "media flow-around" command. I know have Cisco SIP to 3rd party SIP working correctly, with direct RTP stream. However when testing Cisco SCCP and Cisco SIP I get the following: In both cases, SCCP to SIP and from SIP to SCCP the RTP stream goes via CME. Also another problems is introduced when calling from SCCP to SIP, oneway voice (SCCP can hear SIP phone but SIP phone cant hear SCCP)

Paolo Bevilacqua Wed, 10/17/2007 - 03:49

For the one-way voice issue, can you pls upgrade to 12.4(11)XJ4 and try again.

The flow-through method with sccp to sip may be indeed the expected behavior.

glenn.hunter Wed, 10/17/2007 - 04:20

I will do an upgrade on the 2811, but can you confirm the correct behavior of the RTP stream between SCCP and SIP. thanks

glenn.hunter Thu, 10/18/2007 - 22:13

I have upgraded from c2800nm-spservicesk9-mz.124-11.XJ.bin to c2800nm-spservicesk9-mz.124-11.XJ4.bin to see if I could fix the oneway voice problem but the problem still remains.

Paolo Bevilacqua Fri, 10/19/2007 - 02:03


As I said before, from what I see, that is the normal behavior. Media for SIP to SCCP calls goes through the router.


This Discussion