TSP - dialing from Outlook in CM 5.1.2

Answered Question
Oct 15th, 2007
User Badges:

My customer had a demo of the TSP dialing from Outlook at one of Cisco's buildings a few months ago. They really liked the feature and ended up purchasing a new system with us - CM 5.1.2 and Unified Messaging.


So here's my dilema - I can't get the plugin to work properly. I've tried loading the plugin on a couple different PC's and they don't show the ciscoTSP driver under phone/modem. I tried adding it manually - no dice.


At some point I installed it on my laptop and got the driver to show up but when I try to configure the settings in outlook, the Cisco Line isn't there. I have verified the right IP address for CTI Manager. I also made sure my login ID was a member of the CTI Enabled group in Callmanager.


Has anyone seen this work in CM 5.1.2? TAC flat out told me no, but if it was demo'd at Cisco, it should work.

Correct Answer by Rajesh Revuru about 9 years 7 months ago

It worked fine, i had the user to be in "CTIEnabled" and CTIEnduser" groups, and i had the device association with user. So it baseically worked.


We used 3rd party plugin from netelligent, i guess they have free plugin.

http://www.netelligent.com/


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Rajesh Revuru Mon, 10/15/2007 - 08:49
User Badges:
  • Silver, 250 points or more

I had similar scenario, where it showed up 20 desktops and not on other remaining 10. We ended up using some 3rd party tool.



jake-savage Mon, 10/15/2007 - 08:50
User Badges:

Did you ever get it working? I'm getting errors in my log files saying something to the effect of "unable to contact CTI Manager". I don't get it because I can connect to the server via the IP address.


What was the 3rd party tool you used?

Correct Answer
Rajesh Revuru Mon, 10/15/2007 - 08:57
User Badges:
  • Silver, 250 points or more

It worked fine, i had the user to be in "CTIEnabled" and CTIEnduser" groups, and i had the device association with user. So it baseically worked.


We used 3rd party plugin from netelligent, i guess they have free plugin.

http://www.netelligent.com/


jake-savage Mon, 10/15/2007 - 10:16
User Badges:

I just tried the netelligent client and that worked pretty well. I wish there was more info from Cisco on the TSP client because they've obviously got it working someway or another. All I got from TAC was a PDF for installation and configuration AND a nice big disclaimer that says "TAC does not support the processes within this document". WTF?

jake-savage Mon, 10/15/2007 - 10:20
User Badges:

Oh yea, I only had CTI Enabled group on my CM install, not CTI End User. Even with my user account in the Enabled group, the line never showed up in the dial properties.

thisisshanky Mon, 10/15/2007 - 10:28
User Badges:
  • Purple, 4500 points or more

Even buying the Netelligent client plugin for outlook is not expensive. 15$ a license.

jake-savage Mon, 10/15/2007 - 11:12
User Badges:

They have a free version I tried earlier. It worked fine, no problems at all...only bad part is you have to register online each time you install.

thisisshanky Mon, 10/15/2007 - 13:28
User Badges:
  • Purple, 4500 points or more

Only problem with free edition is that it pops up with ads of the product from time to time. Paying 15$ is worth it if you are annoyed with the ad.

We have the same problem with it not showing up in the control panel /modems/advanced.


Only happens on sp2 xp machines. Xp sp1 works fine.


I also noticed on the computers that it doesn't show up in control panel ....


The reg key


hklm\software\micorsoft\windows\currentversion\telephony\providers\


Cisco provider tsp file is not listed there. And if you add it , it will show up but the configure button will not highlight :(


jake-savage Fri, 10/19/2007 - 13:22
User Badges:

Finally got the Cisco TSP working. Here are the instructions:


Try this:


On the client:


1. Make sure you do a clean install on a system that had no TSP before.

2. After install go to control panel > Phone and Modem Options > advanced > select CiscoTSP001.tsp, click configure.

3. The user should be an end user in CallManager, make sure the password is correct.

4. Make sure the correct CTI manager IP address is present.

5. On the security tab I only provided the TFTP address.

6. other configuration settings are default

7. make sure you manually install the Wave drivers.


On CCMadmin:


1. Check that the end user has one controlled device

2. the user is part of the standard cti enabled and CCM End Users groups

3. the primary extension has been configured correctly

4. On the device: enable "Allow Control of Device from CTI", put the correct "Owner User ID"

5. On the line: enable "Allow Control of Device from CTI"


After all of the above has been configured/verified:

1. restart the CTI Manager service

2. reboot the client machine (was necessary for me to get it to work)


Testscenario:

1. On the client go to C:\Program Files\Windows NT and open dialer.exe

2. go to edit > options.

Preferred line for calling: "phone"

line used for phone calls: "Cisco Line: ..."

3. click dial, select phone call, enter the digits of the number you are trying to dial

lwai Sat, 10/20/2007 - 05:11
User Badges:

I have the same issue in upgrade from CM 4.1(3) to 5.1(2b). The TSP worked OK in CM 4.1

(3). after upgrade to CM5.1(2), re-install the TSP program downloaded from CM, the program can detect the old TSP and peform upgrade. After reboot the PC, no cisco phone line is detected.

The TSP program seems cannot upgrade old TSP program. We tried un-install the TSP and re-install it, the same result.

Case is openend and awaiting reply from Cisco.

I tried install the Netelligent program and CANNOT get the license key. It indicate "server not connected, please try after some time". I cannot search the way to get the licencse key from netelligent.com.

Please show me how to get this license key, thanks!

jake-savage Sun, 10/21/2007 - 11:40
User Badges:

With the netelligent program I'm pretty sure you have to register the software on each machine unless you purchase licenses directly from the company. When I installed it, I was given an option to register, I clicked OK and had to type in name, address, phone number, etc. After that I was emailed a license key.

lwai Sun, 10/21/2007 - 19:52
User Badges:

Hi Jake,

Thanks for your reply. After open the outlook after the intsallation of netelligent outlook dialer. The screen display three options for me.

1,apply license key,

2, purchase online

3,register for free version.

I click register for free version and continue several times, it still display "server not connected, Please try after some time". Actually, my PC can reach internet and reach the web site. I think it may be the registation server is down or the free for trial is removed.

If I click purchase online , the same result as before.


cuevas Mon, 04/28/2008 - 11:04
User Badges:

I'm following your steps above and on this step: 4. On the device: enable "Allow Control of Device from CTI", put the correct "Owner User ID"


the 'Owner user Id" is greyed out for me. how do I enable that ?

jake-savage Mon, 04/28/2008 - 12:00
User Badges:

Hmm, I seem to remember having this problem. I can't remember what the fix was though...

cuevas Mon, 04/28/2008 - 12:11
User Badges:

Could it be that i'm doing LDAP Sync?? it shouldn't matter though

cuevas Mon, 04/28/2008 - 10:39
User Badges:

I'm running CCM 5.1.2 and I do not see CTi End User as a Group or Role. Where do you see this?

jake-savage Mon, 04/28/2008 - 10:43
User Badges:

Hm, I think you misread. It should be "standard CTI enabled" under the groups.

cuevas Mon, 04/28/2008 - 10:48
User Badges:

ahh i gotcha! Also i'm attempting this on a XP SP2 machine, should the XP Firewall be turned off?

jake-savage Mon, 04/28/2008 - 10:49
User Badges:

I can't remember if it was on or off when I installed. I'm thinking it was on because the admin at our office usually locks that stuff down with group policies.

Actions

This Discussion