Problem between LNS and Radius-Server

Unanswered Question
Oct 15th, 2007


we're running a c7204 as lns to terminate PPPoE users comming in via

l2tp. Authentication and accounting is handeled by radius. Sometimes

after 1 day, sometimes after 3 days all ppp sessions gets down, no

re-login is possible.

At this time i see many errors in radius.log like "Error: rlm_radutmp:

Logout for NAS lns1 port 233, but no Login record"

After reloading the cisco all works fine for 1-4 days.

Any hints ?



lns1#sh run | i aaa

aaa new-model

aaa authentication login default group ourradius local

aaa authentication ppp Upstream-AAA group ourradius

aaa authorization network Upstream-AAA group ourradius

aaa accounting delay-start

aaa accounting network Upstream-AAA start-stop group ourradius

aaa session-id common

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
ebreniz Fri, 10/19/2007 - 13:54

Please add the following to the configuration :

aaa accounting delay-start

and verify if this changes the behaviour. If not please send me "sh tech" from LNS with the new IOS version Could you send as much details as possible about the accounting problem?

. sh ver

. wr t

Is it possible to collect some debugs when this behaviour occurs?

. debug aaa accounting

. debug radius

. debug aaa authentication

kgtnewmedia Wed, 10/24/2007 - 01:20

Sorry for the delay, but I never got a mail that anyone has answered to my topic :-(

Last night we saw the same strange behaivior on the c7204. I will attach some log output to this topic.

I added the command "aaa accounting delay-start" to my config just after the crash tonight.

kgtnewmedia Wed, 10/24/2007 - 01:32

Once again some details:

* on both radius servers the same errors in the logs (Error: rlm_radutmp: Logout for NAS...)

* it is not possible to reach the c7204 over the network (via console only)

* Fa1/0 will going down during this issue


This Discussion