7921 constantly registering

Unanswered Question
Oct 16th, 2007

Hi,

I've a problem with IP Phone 7921 which are often registering.

I've no WLC and use WPA LEAP.

I suppose it's a roaming problem?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
schunt Wed, 10/17/2007 - 17:26

Hi,

We need more information regarding your issue.

What firmware are you running on the phone?

When you say it is "often registering", do you mean it is disassociating and reassociating with the AP or is it constantly re-registering with CUCM. Also, please provide information about your wireless environment.

Thanks,

Scott

guilhem.perez Wed, 10/17/2007 - 23:10

Hi,

thanks for your reply.

The firmware is 1.0.4.

When I say they often registers, they dissaociate and reassociate unlike phone are not moving and they register unregister on callmanager.

While they are not register (sometimes a long time), it's possible to ping them from callmanager)

My wireless environment is composed by 23 Access Point without controller.

The security is 802.1x (AKM WPA with username and password). 1 ap is radius server.

I disable data rate lower than 11Mbit, 11Mbit mandatory and uper data rate enable.

I disable all channel not used on phone (let only 1 6 and 11).

I try lowering power on AP but I think it's not better.

I plan to do a site survey to check if there are interferences

Thanks

schunt Thu, 10/18/2007 - 06:02

Hi.

Thanks for the information. Your idea of a site survey is a good idea to make sure that you do not have any interference. Make sure that you do not have any 2.4GHz phones in the environment. Let us know the results of your site survey.

Scott

migilles Wed, 10/24/2007 - 16:03

Would suggest to look at the WLAN sniffer or 7921 log to see which side is sending the TCP reset.

If not 802.11 disassociation or roaming event, then no reason why TCP should be reset unless done via admin using CCMAdmin or if the device is not ACKing the SCCP packets from the CallManager either due to out of range, interference, etc.

Maybe you should open a TAC case to seek further assistance.

stahkaoja Thu, 10/25/2007 - 22:22

Hi all,

We have excactly the same kind of problems. We have 140x 7921G (FW 1.04), 8x 7920 (FW 3.02) and about 140x Cisco 12xx access points. No controller. Voice is separated to own VLAN. Switches are 2x 4506(L3) and the rest are 5x 3508 and >50x 2940,2950,2960. The phones get their addresses from DHCP. CCM is 4.1(3)SR4d.

The 7920's seem to work fine, but the 7921's do that re-registering process quite often. Also one-sided audio is sometimes a problem, along with the fact that if phone rings, you can't answer to it no matter what key you press...

When looking in the 7921G status messages, after it has re-registered, it says DHCP timeout. The thing is, that in the office, we have 3 AP's. For example, my workplace has signal strengths -50, -70, and -80. The phone seems to prefer to get the signal from the weakest -80 (only 1 bar of signal strength). Even if the -50 AP has only few clients associated to it.

I guess there could be something wrong with the Firmware 1.04. I THINK that we didn't have those problems with 1.03. However, I would not like to revert back to 1.03, because it had some bug, that is quite critical to our system (and it was corrected in 1.04)

-Sami

migilles Fri, 10/26/2007 - 17:39

No known issues in this area with 1.0.4, so would tend to point to RF or network related.

Open a TAC case if you need further assistance.

mparmigiani Sun, 10/28/2007 - 16:41

Good evening,

I' m having the same kind of problem.

My scenario is:

- n. 20 7921G firmware version 1.0.4

- Access Point Symbol

- separate Vlan for Voice

My problems are:

- very often Wireless Ip Phones register

- very often customer receive ring and is not able to answer (using green botton or answer button or othe button)

With version 1.0.3 there wasn' t this kind of problem ?

Some more informations:

- ping to Wireless Ip Phone when is not in connection is about 1.000 msec

- ping to Wireless Ip Phone whes is in connection is about 10-15 msec

Marco Parmigiani

guilhem.perez Sun, 10/28/2007 - 16:56

not yet,

I read there are some important bugs

but I think I will try as soon as I have time to do it in ly lab.

stahkaoja Sun, 10/28/2007 - 23:06

Hello again,

Just to provide some more information about our system... We don't have any authentication or encryption in our voice-VLAN (only hidden SSID). They are used in underground mine. That also rules out any RF-pollution from other sources... The network should be more than ok. Standard Cisco equipment with spanning-tree and all that. The overall network utilization is quite low.

Also the fact that the older 7920's work extremely good - no problems at all, suggests that there could be something firmware-related problems.

-Sami

migilles Mon, 10/29/2007 - 08:53

Wouldn't jump to conclusions so fast without evidence.

The 7920 and 7921 are totally different devices. 7921 has WMM, CAC, OFDM support, many differences.

drees Wed, 10/31/2007 - 09:28

Did you get this resolved? I'm having the same problem with a new installation, four autonomous 1242AG access points with 7921 phones. They drop their registration from CCM and one of the phones won't get an IP address, but works intermittently with a static IP. Signal strength and SNR values are great, but phones still have registration issues with CCM. We've tried fw 1.03 and 1.04 with no change.

Just wondering if you found a resolution or a direction for troubleshooting.

Thanks.

Dave

asafayan Wed, 11/14/2007 - 11:05

We have a 15 WLC (4.0.217.0), 600 APs, 300 7921 (1.03) and utilize EAP-FAST.

We intermittently have single digit audio delays that often occur at the beginning of calls, and also occur during the middle of calls and phones that spontaneously unregister/re-register.

Any suggestions to improve these symptoms would be much appreciated!

TIA

mparmigiani Wed, 11/14/2007 - 13:11

Hi,

it' s two days that Cisco IP wireless phones 7921G are working fine. I've Symbol AP, not Cisco AP.

My initial problems:

- very often Wireless Ip Phones register

- very often customer receive ring and is not able to answer (using green botton or answer button or other button)

After some modifications where we solved theese two points there was yet another problem:

- when user answer, he has to wait 1/2/3 seconds or more to hear voice.

The final solution was:

- downgrade Symbol WS 5100 from version 3.0.2 to version 2.1.2

- Used ACS (Automatic Channel Selection) to determine the best channel selection for AP and fixed them

- Modified DTIM parameter from 10 to 2 (I think this parameter solved the late start of voice stream)

- Enabled only 1 2 Mb basic and 5,5 11 Mb supported frequency (if everything will work I'll try to enable 36 and 54 Mb).

- 80% Bandwidth for Wlan VoIP and 20% for Wlan Data

- Access point restart

I hope this help for you.

Bye

Marco

mparmigiani Wed, 11/14/2007 - 13:14

Hi,

and I modified on 7921G following parameter:

- Mobility Power saving to Nothing (default U-APSD/PS-POLL).

Bye

Marco Parmigiani

migilles Thu, 11/15/2007 - 08:33

Yes just received word from another customer they are seeing buffer overflows when using PS-POLL with the Symbol WLC w/ just a few 7921 clients associated.

Symbol doesn't support U-APSD.

So until Symbol can address this issue, the workaround is to put the on call power save mode to "None", where the phone will use active mode when on call.

Will still use PS-POLL when in idle though.

Granted this is not a good workaround as then the users may start to complain of poor battery life. Should expect to get about 50% of the advertised talk time (10 hours for standard battery), so looking something like 5 hours, which is much like the 7920 phone.

g.rienstra Thu, 12/13/2007 - 07:50

HI,

Is your issue resolved? i havethe same issue!!

One way speech, reregistering etcetc. I do suspectthe firmware. changes in QOS and USD-poll did not resolve mij problem..

Please let me know.

Cheer.

Goen

dytechitsolutions Thu, 02/16/2012 - 06:38

Has anybody a solution for this Problem?


Our Customer has a UC540 SW-Pack 8.2 and two AP541n & two 7921G FW-1.4.2 phones.

The 7921G has  a lot of problems in this environment - we open a TAC and the SE said we must disable all other VAPs on the 541n AP. This helps for the problem to answer a call. But the phones register and unregister all the time, and this is no stable solution. We change Keepalive to 10, and try to disable the Moh - without any changes.
Furthermore this is no Solution, to disable all other VAPs then for the VoIP-Vlan.

It is realy urgent! The custumer is very angry about several different problems with the 7921G phones and the many bugs with the current firmware of the UC.


Thanks
Albrecht

migilles Thu, 02/16/2012 - 09:31

Have you provided WLAN sniffer traces to TAC to analyze to see what is causing the frequent deregistering?

Also is this deregiatration from CME or disassociation from the AP?

Sent from Cisco Technical Support iPhone App

dytechitsolutions Fri, 02/17/2012 - 00:54

The 7921G has a good WiFi access. About -35 to -45 RSSI. The problem might be a problem with the AP541N because if i disable the AP and enable the AP of the UC540 it works. But the UC540 is insight a Rack and the WiFi is not huge for the enviroment. So we disable the UC540 WLAN an add two AP541N.

I will use a WiFi sniffer today an provide the analyse to TAC. But in my opinion this is a problem with 541N.

050280: Feb 12 14:23:18.028: %IPPHONE-6-REG_ALARM: Name=SEPC89C1DXXX Load=CP7921G-1.4.2 Last=TCP-Zeitüberschreitung

050281: Feb 12 14:23:18.236: %IPPHONE-6-UNREGISTER_ABNORMAL: ephone-12:SEPC89C1D92339E IP:10.1.1.22 Socket:4 DeviceType:Phone has unregistered abnormally.

050282: Feb 12 14:23:18.240: %IPPHONE-6-REGISTER: ephone-12:SEPC89C1D9XXXX IP:10.1.1.22 Socket:7 DeviceType:Phone has registered.

Thanks

Albrecht

Actions

This Discussion