Spantree portfast enable but port goes into listening/learning

Answered Question
Oct 16th, 2007
User Badges:

Hello:

I was wondering if anyone has any info or experience on why the following is happening in our Data Center ServerFarm Access switch.


Switch is WS-C2948G-GE-TX running CAT OS 8.4(11)GLX. It is configured with Rapid-PVST+ spanning-tree in mixed environment with PVST+ spanning-tree within the server farm.

Ports directly connect servers are trunked ports with portfast enable.

When the port goes up/down spanning tree goes into listening and learning modes even though portfast is configured on the ports.


Does anyone know what could cause this?


Thanks in advance for your help.

Tony

Correct Answer by rainergoldmann about 9 years 6 months ago

hi,

if you want to set a trunk to portfast on catos

use:

set spantree portfast enable trunk



hope this helps


bye ray

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
rainergoldmann Tue, 10/16/2007 - 10:43
User Badges:

hi,

if you want to set a trunk to portfast on catos

use:

set spantree portfast enable trunk



hope this helps


bye ray

amaiale Tue, 10/16/2007 - 10:57
User Badges:

Ray,


Thanks for your quick response. I did verify that the switch OS does support what you recommended and will add the "trunk" command to all trunk links requiring portfast.


Thanks again for your help.

Tony

Actions

This Discussion