DHCP NAT help

Unanswered Question
Oct 16th, 2007
User Badges:

I am trying to have my router hand out dhcp private addresses and have those natted to the public network. Here is what I have so far. I believe i am missing the acl but have no idea what is would look like.


Current configuration : 878 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Efrain

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

ip dhcp excluded-address 192.168.1.1 192.168.1.40

!

ip dhcp pool Chiefs

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.1.5

!

ip dhcp pool chiefs

domain-name kcpl

lease 15 23 59

!

!

interface FastEthernet0/0

ip address 144.x.x.1 255.255.255.0

ip nat outside

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 192.168.1.20 255.255.255.0

ip nat inside

duplex auto

speed auto

!

ip http server

ip classless

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mzsrtgzr_cisco Tue, 10/16/2007 - 10:51
User Badges:



hey,

The dhcp process doesn't interfere with nat.

in this answer i'll be assuming that you want to overload the inside addresses.

1st: configure access-list for your "inside"

access-list 1 permit 192.168.1.0 0.0.0.255


2nd: configure the global nat statement:

ip nat inside source list 1 interface f0/0 overload


i hope this helps


gonzalezel Tue, 10/16/2007 - 10:59
User Badges:

thanks for your help, I'm really confused but starting to understand this. How would I go about testing this when all I have is 2 2621xm and a laptop?

mzsrtgzr_cisco Tue, 10/16/2007 - 11:09
User Badges:

laptop --> with cross cable --> router f0/1.

then plug f0/0 with a cross to the other router.


gonzalezel Tue, 10/16/2007 - 11:59
User Badges:

I did this and was able to receive private dhcp but I don't get anything when doing "sh ip nat translations" on the router, is this correct?

Actions

This Discussion