QoS on dialer 0

Unanswered Question

I am unable to get service-policy working on a dialer interface, config below:


class-map match-all voice_ccoip

match access-group name CLASS_1

!

!

policy-map voice_ccoip

class voice_ccoip

priority 128

class class-default

fair-queue

policy-map shape

class class-default

shape average 256000

service-policy voice_ccoip


Whenever I apply it to the dialer 0 interface I get the following error:


GTS : Not supported on this interface


I am new to QoS, anyone explain what I have done wrong?

Router is 2811 with WIC-1ADSL, 12.4 SP Services.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shane.orr Wed, 10/17/2007 - 04:19
User Badges:
  • Silver, 250 points or more

Someone will have to correct me if I am wrong but CBWFQ is not supported on Virtual interfaces like Dialers, - basically it tries to apply hardware queueing on a virtual interface. You can use nested policy-maps though. Here is an example of what I had to do for a connection that the provider had given me where 6 megs where for internet and 14 megs were for MPLS connection and in order to apply QoS to a sub-interface I used nested policy map but it will be the same concept for Dialers I believe.



class-map match-any VoIP-Control

match ip dscp cs3

match ip dscp af31

class-map match-any VoIP-RTP

match ip dscp ef

!

!

policy-map WAN-EDGE

class VoIP-RTP

priority 768

class VoIP-Control

bandwidth percent 5

class class-default

fair-queue

policy-map MPLS-14Meg

class class-default

shape average 14000000

service-policy WAN-EDGE

policy-map Internet-6Meg

class class-default

shape average 6000000


interface Serial1/0

description WAN/MPLS

bandwidth 20000

!

interface Serial1/0.1 point-to-point

bandwidth 14000

service-policy output MPLS-14Meg

!

interface Serial1/0.2 point-to-point

bandwidth 6000

service-policy output Internet-6Meg

paolo bevilacqua Wed, 10/17/2007 - 06:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try applying the service-policy to the physical interface underlying the dialer interface.


Hope this helps, please rate post if it does!

Thanks for your response


I have tried entering it on to atm0/0/0, atm0/0/0.38 and on to the PVC. I get the same GTS: Not supported on this interface on 0/0/0 & 0/0/0.38, I tried it on the PVC 0/38, it goes in but does not appear in the config. I have read up on the subject and you can apply it to virtual interfaces just as long as the CBFWQ is nested and I am sure this config is.


The ATM interfaces I have are as follows:


interface ATM0/0/0

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.38 point-to-point

ip nbar protocol-discovery

no ip route-cache

no ip mroute-cache

pvc 0/38

tx-ring-limit 60

encapsulation aal5mux ppp dialer

dialer pool-member 1


paolo bevilacqua Thu, 10/18/2007 - 03:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


Which hardware is this ATM interface ?

In reality you do not need to shape first, because you are limited by the upstream speed. You can also easily configure an ubr rate and that will be you "shaping speed".

Actions

This Discussion