AMD CPU with Vista cannot connect to WLAN using MS-PEAP with WEP-128

Unanswered Question
Oct 16th, 2007

We have a notebook "HP Pavilion tx1000 (AMD Turion64 CPU with Vista 32bits)". The notebook is using Broadcom 802.11a/b/g chipset, running AMD and Vista. It cannot associate to WLAN using MS-PEAP and WEP-128. Also, it cannot associate to PEAP and WPA2-AES.

The AP's log shows:

Oct 11 15:35:20 CCT: %DOT11-7-AUTH_FAILED: Station Authentication failed

The ACS's log shows:

"EAP-TLS or PEAP authentication failed during SSL handshake"

We do not validate the certificate in the wireless setup. Vista's WLAN AutoConfig is used to configure the wireless profile. We are running Autonomous AP with Switch-Based WDS (WLSM).

We have no issue with Intel Centrino on the above authentication and encryption scheme.

Have checked the CCX program, broadcom 802.11a/b/g chipset is supported only for windows 2000 and xp. There is no mentioning about support for vista. Could this be a compatibility issue?

Please advise and thks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pppyyyppp Tue, 10/16/2007 - 20:56

We have no issue with using Intel Centrino Wireless Chipset with MS-PEAP WEP-128. As describe in the earlier post, the issue only happens with Broadcom 802.11abg chipset on HP laptop. We do not enabled CCKM. Appreciate if you could advise.

dennischolmes Wed, 10/17/2007 - 11:11

This is a huge compatability issue. I have one of these laptops myself for lab purposes and it not only causes problems with EAP/ PEAP. It shows all sorts of other instability issues when used with Vista. Broadcom has a new driver that helps some of the issues when using AES encryption, but so far nothing has fixed my connection problems. A lot of those problems reside way down at the mac layer and with association to any access point. It even fails on linksys with psk.


pppyyyppp Wed, 10/17/2007 - 15:34


I have download the latest driver from HP website for the Broadcom 802.11abg chipset. However, it still does not solve my problem.

May I know where in Broadcom website you download your driver/firmware and also what the exact name of the Broadcom 802.11abg chipset in the HP machine. The HP laptop only show Broadcom 802.11abg.

dennischolmes Wed, 10/17/2007 - 16:38

I downloaded the driver. This is supposed to be for all broadcom 802.11a/b/g internal cards. It really didn't help me either. The problem is Vista. No driver is really stable there yet. Buy yourself some atheros based cards.

pppyyyppp Wed, 10/17/2007 - 19:36

Dennis, driver is also the driver I am using and it too does not help. Do you log a case with HP support on this and if yes, what do they say.

Except to wait for Msoft to release a working vista driver, are there anything that can be done?

dennischolmes Sat, 10/20/2007 - 07:48

I placed a call to HP support nearly 4 weeks ago and as of yet they have given no response. I am sure they are screaming at broadcom as well.

pppyyyppp Sun, 10/21/2007 - 15:28


Since its already 4 weeks, perhaps you might want to check with HP support (just in case, they forget your case totally). Once you got any update, do update in this forum.

dennischolmes Mon, 10/22/2007 - 17:46

I talked with HP today and they still say there is no known problem. I guess they don't look on the web very often. They wanted me to download the newest drivers, funny, I already have. DUH! I'll keep ya posted.


This Discussion