APs and switch voice vlans also supporting data traffic

Unanswered Question
Oct 17th, 2007

hi, i hv a wireless IP phone,AP, 2960 switch1 and another 2960 switch2. My question is, if i configured voice vlans on th access ports on th switch1 (for voice and data), this switch1 is connected to the AP and the IP phone gets connected to the AP somehow (please guide),will this configuration work or i m missing alot of info.?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
srahn Wed, 10/17/2007 - 07:26

If you're using autonomouns (IOS, i.e. non-controller based) AP's, the preferred method of segmentation is to create your different voice, data, network mgmt vlan's on the switchs. Created the same vlan's on the AP using the sub-interfaces (CLI) or GUI vlan configuration. Ensure QoC is configured on both the AP and the swithces, then trunk the connection btw the AP and the switch.

jerryeguru Thu, 10/18/2007 - 01:33

thx srahn, 1 more question, if i configured a single voice vlan on my switch1 (supporting data and voice)like this..

voice vlan on switch1:

mls qos

interface fastethernet 0/1

description connection to Accesspoint1

mls qos trust cos

switchport mode trunk

switchport mode encapsulation dot1q

switchport voice vlan 10

switchport priority extend trust

interface fastethernet 0/0

description connection to switch2 for inter-vlan

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

--------------------------------------------------------------------

Then a native vlan on AP like this ...

interface fastethernet 0.2

encapsulation dot1q 2 native

interface dot11radio 0.2

encapsulation dot1q 2 native

--------------------------------------------------------------------

Voices (vlan 10) vlan on AP like this ...

interface dot11radio 0

ssid voices

vlan 10

authentication open

interface fastethernet 0.10

encapsulation dot1Q 10

bridge-group 10

interface dot11radio 0.10

encapsulation dot1Q 10

bridge-group 10

---------------------------------------------------------------------

Looking at this configuration examaple, how do i support voice and data traffic on th vlans on the AP.... Do i also have to configure a native vlan (for data) on switch1? b'se i intend to have 1 vlan tht supports both voice and data.

**** Will the configuration above work for my network?

Actions

This Discussion