cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
233
Views
0
Helpful
1
Replies

Can I run multiple dial pools on an Ethernet interface on my 1721?

erik.doss
Level 1
Level 1

I am attempting to configure a 1721 for a remote property that uses DSL with a DSL modem that will go into an ethernet WIC on a 1721. Since I don't know if the ISP uses chap or pap, i was wondering if I could run two dial pools on the ethernet0 interface, with one dialer set up for chap, and the other set up for pap, both with the same IP address. Here is the config I have so far:

interface Ethernet0

no ip address

ip virtual-reassembly

full-duplex

pppoe enable

pppoe-client dial-pool-number 2

pppoe-client dial-pool-number 1

no cdp enable

!

interface FastEthernet0

description local LAN

ip address 10.*.*.* 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

no cdp enable

!

interface Dialer0

no ip address

shutdown

!

interface Dialer1

ip address *.*.*.169 255.255.255.248

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname ****@pacbell.net

ppp chap password 7 ************************

crypto map rdln_map

!

interface Dialer2

ip address *.*.*.169 255.255.255.248

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 2

dialer-group 2

ppp authentication pap callin

ppp pap sent-username ****@pacbell.net password 7 ****************************

crypto map rdln_map

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

Will this even work? Or can I only have one dial pool on the ethernet0 interface? If I can have both, it would make things a little easier when I send it to the property.

Any suggestions to tweak up what I have is appreciated... thanks!

1 Reply 1

erik.doss
Level 1
Level 1

I think I figured this out... here is what I did:

interface Ethernet0

no ip address

ip virtual-reassembly

full-duplex

pppoe enable

pppoe-client dial-pool-number 2

pppoe-client dial-pool-number 1

no cdp enable

!

interface FastEthernet0

description local LAN

ip address *.*.*.254 255.255.255.0

ip nat inside

ip virtual-reassembly

speed auto

full-duplex

no cdp enable

!

interface Dialer0

no ip address

shutdown

!

interface Dialer1

ip address *.*.*.169 255.255.255.248

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname ****@pacbell.net

ppp chap password 7 **********************

ppp pap sent-username ****@pacbell.net password 7 *************************

crypto map rdln_map

!

interface Dialer2

ip address *.*.*.169 255.255.255.248

ip access-group 102 in

ip mtu 1492

ip inspect FIREWALL out

ip nat outside

ip virtual-reassembly

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

shutdown

dialer pool 2

dialer-group 2

ppp authentication pap callin

ppp pap sent-username ****@pacbell.net password 7 ************************

crypto map rdln_map

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip nat inside source route-map nonat interface Dialer1 overload

Does this look right?

BTW, does anyone know how to remove the second pppoe-client (pppoe-client dial-pool-number 2) statement from my ethernet0 interface? It doesn't seem to want to go away :)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card