DHCP & VLAN Incorrectly assign IP addresses

Unanswered Question
Oct 17th, 2007
User Badges:

I have an issue recently that a PC connected on VLAN106 (SALES) kept getting a DHCP leased IP address from a DHCP server on VLAN 100 (TECH). I do not have this issue with any other VLANs so I am thinking right after the sales folks made some move they have accidentally crossed the two VLANS and created a switching loop or bridged the two VLANs. How do I go about troubleshooting this issue? Please let me know if you guys have questions or need further clarification. Thank you all in advanced.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bryanvtran Wed, 10/17/2007 - 14:46
User Badges:

Also, it's not just happening to a single PC but with all PCs in VLAN106 (SALES). I had to take the DHCP server in VLAN100 offline in order get this going as a work around. I've also verified the "ip helper address" and that is only set to the correct on for VLAN106.

dinesh.thathana... Thu, 10/18/2007 - 01:52
User Badges:

Can you check the DHCP Scopes on the Server also?.


What is the gateway for the users?. I am assuming users are on access switches and the G/W is on a Core s/w.

andrew.butterworth Thu, 10/18/2007 - 10:38
User Badges:
  • Gold, 750 points or more

My assumption is that the DHCP Scopes for VLANs 106 and 100 are in the same DHCP SuperScope?

If that's the case remove the SuperScope and have them as two separate scopes.

SuperScopes look like they are a nice way to group DHCP Scopes, believe me they aren't. What they do is assume all the IP networks/subnets in the SuperScope share the same broadcast domain. They are only useful when you use secondary addresses.


HTH


Andy

bryanvtran Fri, 10/19/2007 - 10:09
User Badges:

Thank you all for replying.


To java.util.regex.Matcher[pattern=[a-zA-Z0-9_+-.]+@[a-zA-Z0-9][w.+-]+.[a-zA-Z]{2,} region=0,1023 lastmatch=[email protected]]: What do I need to look for on the DHCP server scope? Gateway is assigned by the DHCP server scope accordingly. VLAN106 leases will contain 10.100.16.x/23 addressing. VLAN100 leases will contain 10.100.10.x/23 addressing.


To java.util.regex.Matcher[pattern=[a-zA-Z0-9_+-.]+@[a-zA-Z0-9][w.+-]+.[a-zA-Z]{2,} region=0,1023 lastmatch=[email protected]]: The reported DHCP servers are not in question and are legit.


To andrew.butterworth: Yes, I am running Windows server 2003 DHCP superscope and according to your explaination it could be the issue. But I just don't understand why it's happening now right after the Sales folks moving around? And this is why I am thinking it could be a bridge/loop between the two VLANS mentioned. Other VLANs are not experiencing this issue. It has been working ok by designed with the Windows SuperScope setup. I would appreciate it if someone has the how-to or best practices for setting up Windows DHCP server to serve the multi-VLAN segments. I can't have a DHCP server for every VLAN, that would be unreal right?

bryanvtran Fri, 10/19/2007 - 14:11
User Badges:

Also, Andy if you don't mind would you please explain the use of a secondary addresses on the DHCP server? Thank you.

Actions

This Discussion