Help me to setup this VLAN

Unanswered Question

Hi everyone,

I am practicing to setup a VLAN as shown in the figure http://blog.erealmedia.com/

I am using Packet Trace 4.1 from CISCO.

So far I have able to create VLANs 1, 22, 33 and 44. Have created Trunk ports and they are working fine. I can create and delete VLANs, add access ports to VLANs

The problem is that I don't know how to configure layer 3 IP address and use the router to route traffic from different VLANs for inter VLANs communication

Some of the Screenshots for better picture

Sw-AC3#Show vtp status

VTP Version : 2

Configuration Revision : 6

Maximum VLANs supported locally : 64

Number of existing VLANs : 8

VTP Operating Mode : Server

VTP Domain Name : CCNA

VTP Pruning Mode : Disabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xD0 0x1D 0xB8 0x50 0x0E 0x52 0xA8 0xEF

Configuration last modified by 0.0.0.0 at 3-1-93 00:58:10

Local updater ID is 192.168.44.254 on interface Vl44 (lowest numbered VLAN interface found)

Sw-AC3#show spanning-tree

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 000C.CFCA.A0D2

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 000C.CFCA.A0D2

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Desg FWD 19 128.3 Shr

Fa0/3 Desg FWD 19 128.3 Shr

Fa0/5 Desg FWD 19 128.3 Shr

VLAN0022

Spanning tree enabled protocol ieee

Root ID Priority 32790

Address 000C.CFCA.A0D2

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32790 (priority 32768 sys-id-ext 22)

Address 000C.CFCA.A0D2

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Desg FWD 19 128.3 Shr

Fa0/3 Desg FWD 19 128.3 Shr

Fa0/4 Desg FWD 19 128.3 Shr

VLAN0033

Spanning tree enabled protocol ieee

Root ID Priority 32801

Address 000C.CFCA.A0D2

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32801 (priority 32768 sys-id-ext 33)

Address 000C.CFCA.A0D2

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Desg FWD 19 128.3 Shr

Fa0/3 Desg FWD 19 128.3 Shr

VLAN0044

Spanning tree enabled protocol ieee

Root ID Priority 32812

Address 000C.CFCA.A0D2

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32812 (priority 32768 sys-id-ext 44)

Address 000C.CFCA.A0D2

Aging Time 300

Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.3 Shr

Fa0/2 Desg FWD 19 128.3 Shr

Fa0/3 Desg FWD 19 128.3 Shr

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Wed, 10/17/2007 - 23:49

Hi

You need to use a router on a stick configuration to make this work.

Assumung your router is capabale of doing this. Substitute the IP addresses i have used with your own.

int fa0/0.1

encapsulation dot1q 1

ip address 192.168.1.1 255.255.255.0

int fa0/0.22

encapsulation dot1q 22

ip address 192.168.2.1 255.255.255.0

int fa0/0.33

encapsulation dot1q 33

ip address 192.168.3.1 255.255.255.0

int fa0/0.44

encapsulation dot1q 44

ip address 192.168.4.1 255.255.255.0

Your interface numbers do not have to match the vlan ie.

int fa0/0.2

encapsulation dot1q 22

ip address 192.168.2.1 255.255.255.0

would be just as valid. The "encapsulation dot1q "vlan number" must have the correct vlan number.

Then you need to make the port on the switch that the router connects into a

dot1q trunk.

That should do it.

HTH

Jon

Hi Jon Thanks,

I am still trying.... here is the output of router interface

Router#show ip interface

FastEthernet0/0 is up, line protocol is up (connected)

Internet protocol processing disabled

FastEthernet0/0.1 is up, line protocol is up (connected)

Internet address is 192.168.1.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.22 is up, line protocol is up (connected)

Internet address is 192.168.22.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.33 is up, line protocol is up (connected)

Internet address is 192.168.33.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.44 is up, line protocol is up (connected)

Internet address is 192.168.44.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet1/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Serial2/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Serial3/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

FastEthernet4/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

FastEthernet5/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Router#

I hope I am moving right, now I am going to assign IP address to host and assign them VLAN membership according to VLAN IP eg PC1 memeber of VLAN 1 IP in range 19.168.1.1-254

Hi Jon Thanks,

I am still trying.... here is the output of router interface

Router#show ip interface

FastEthernet0/0 is up, line protocol is up (connected)

Internet protocol processing disabled

FastEthernet0/0.1 is up, line protocol is up (connected)

Internet address is 192.168.1.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.22 is up, line protocol is up (connected)

Internet address is 192.168.22.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.33 is up, line protocol is up (connected)

Internet address is 192.168.33.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet0/0.44 is up, line protocol is up (connected)

Internet address is 192.168.44.1/24

Broadcast address is 255.255.255.255

Address determined by setup command

MTU is 1500 bytes

Helper address is not set

Directed broadcast forwarding is disabled

Outgoing access list is not set

Inbound access list is not set

Proxy ARP is enabled

Security level is default

Split horizon is enabled

ICMP redirects are always sent

ICMP unreachables are always sent

ICMP mask replies are never sent

IP fast switching is disabled

IP fast switching on the same interface is disabled

IP Flow switching is disabled

IP Fast switching turbo vector

IP multicast fast switching is disabled

IP multicast distributed fast switching is disabled

Router Discovery is disabled

IP output packet accounting is disabled

IP access violation accounting is disabled

TCP/IP header compression is disabled

RTP/IP header compression is disabled

Probe proxy name replies are disabled

Policy routing is disabled

Network address translation is disabled

WCCP Redirect outbound is disabled

WCCP Redirect exclude is disabled

BGP Policy Mapping is disabled

FastEthernet1/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Serial2/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Serial3/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

FastEthernet4/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

FastEthernet5/0 is administratively down, line protocol is down (disabled)

Internet protocol processing disabled

Router#

I hope I am moving right, now I am going to assign IP address to host and assign them VLAN membership according to VLAN IP eg PC1 memeber of VLAN 1 IP in range 192.168.1.1-254

On each Vlan I have created VLANs sub interface like

configure terminal

interface VLAN 1

ip address 192.168.1.254 255.255.255.0

no shutdown

Configure terminal

interface vlan 22

ip address 192.168.22.254 255.255.255.0

no shutdown

and so on

Actions

This Discussion