MSTP related issue

Unanswered Question
Oct 18th, 2007

Hello Tutor,

I have 2 Vlans, 10 and 20 on my 3560. Now I map instance 1 to vlan 10 and instance 2 to vlan 20.Ge0/1 is a vlan 10 access port and Ge0/2 is a vlan 20 access port. The rest of the configurations are left at defaults. Now I connect another s/w say a 3550 with a simillar configuration in such a way Ge0/1 of 3550 ( access of vlan 10) is connected to Ge0/1 of 3560 and Ge0/2 (access port of vlan 20) is connected to Ge0/2 of 3560. Wht will be state of the ports considering that my 3560 will be the root bridge for both instances.

What i feel is Ge0/1 will be kept forwarding for Vlan 10 and Ge0/2 will bw kept forwarding for Vlan 20. Either of the ports will be blocked for the other Vlan.

Do correct me if i am wrong to state the same.

-/ Kiran.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Francois Tallet Thu, 10/18/2007 - 06:51

Hi Kiran,

That's indeed what is going to happen with Cisco bridges. We tweaked the MST implementation so that we don't send the information for an instance whose mapped vlan don't appear on a given port. For example, there is no vlan mapped to instance 2 allowed on the access port in vlan 10. As a result, we don't send the information for instance 2 over this link. This way, MST 2 does not consider this access link in vlan 10 as a redundant link between the two 3550 and you are sure that the other link (access for vlan 20) will be forwarding. This kind of trick cannot apply to instance 0, that is computed on every port, even access port (thus instance 0 will probably block on g0/2). The goal was to get a behavior closer to PVST so that our users (who are generally used to PVST) are not too confused by MST. I'm not sure if it's a good idea in the long term;-)

If the same scenario was made with two third party bridges, one link would block for all the instances and there would be no connectivity between the two switches for one of the vlan.

Regards,

Francois

kirancherian Thu, 10/18/2007 - 19:33

Aha!! That explains it. I was testing a 3rd party L3 device and I kinda saw this peculiar difference between the two devices for this feature set.

Thank you the info Francois.

-/ Kiran

Actions

This Discussion