CM 5.1 TSP TAPI not connecting to callmanager

Unanswered Question
Oct 18th, 2007

We are installing a third party CTI application to callmanager 5.1 We have installed the TSP from callmanager plugin and configured a user in callmanager, same configuration procedure as previous callmanager versions. We recieve the following error in RTMT

Any help would be great.

70 Oct 18 141202.37 UTC %CCM_CTI-CTI-3-kCtiProviderOpenFailure CTI application failed to open provider CTIconnectionId19 Login User IdTAPIMGR Reason code.-1932787595 IPAddress192.168.200.121 App IDCisco CTIManager Cluster IDStandAloneCluster Node IDCCMSUB

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jake-savage Fri, 10/19/2007 - 13:18

Try this:

On the client:

+ Make sure you do a clean install on a system that had no TSP before.

+ After install go to control panel > Phone and Modem Options > advanced > select CiscoTSP001.tsp, click configure.

+ The user should be an end user in CallManager, make sure the password is correct.

+ Make sure the correct CTI manager IP address is present.

+ On the security tab I only provided the TFTP address.

+ other configuration settings are default

+ make sure you manually install the Wave drivers.

On CCMadmin:

+ Check that the end user has one controlled device

+ the user is part of the standard cti enabled and CCM End Users groups

+ the primary extension has been configured correctly

+ On the device: enable "Allow Control of Device from CTI", put the correct "Owner User ID"

+ On the line: enable "Allow Control of Device from CTI"

After all of the above has been configured/verified:

+ restart the CTI Manager service

+ reboot the client machine (was necessary for me to get it to work)


+ On the client go to C:\Program Files\Windows NT and open dialer.exe

+ go to edit > options.

Preferred line for calling: "phone"

line used for phone calls: "Cisco Line: ..."

+ click dial, select phone call, enter the digits of the number you are trying to dial

littledavewhite Mon, 10/22/2007 - 01:13

Hi Excellent work my friend

This is just what i was looking for. I have now resolved my issue. The user was not in a group with permissions for CTI. This looks like a new configuration requirment from callmanager for windows ?

many thanks

jake-savage Mon, 10/22/2007 - 07:16

In 4.x you needed to have a CTI box checked on their user page in the directory. 5.x and 6.x changed this with groups.

neil.woolloff Tue, 06/24/2008 - 07:04

Appreciate this is old, but was about to follow this through, however, noted that no specific CTI group was mentioned by littdavewhite

Can anybody shed light on which groups are best.




This Discussion