CCVP Lab - PSTN Simulator?

Unanswered Question
Oct 18th, 2007

All,

I am working with a partner on creating a CCVP/CCIE Voice lab to pursue those certifications. We have most of the pieces already in place (voice gateways, routers, switches, CME, CallManager, etc) but I did have one question about setting up a PSTN simulator using a Cisco router. I'm somewhat confused on how best to emulate this technology in a lab environment to help me adequately prepare for those certifications.

http://www.certificationtalk.com:81/showflat.php?Cat=&Board=VGen&Number=29921&page=0&view=collapsed&sb=5&o=&fpart=1&vc=1

That link discusses a config (at the bottom of the page) that will emulate a PSTN connection by basically turning a router into an H.323 gateway (if I understand it correctly, correct me if I'm wrong).

Another link (http://corner-il.blogspot.com/) has instructions for setting up a PSTN emulator using Dynamips running a 2691 image and this config:

Relevant sections of the PSTN router

frame-relay switching

interface FastEthernet0/1

ip address 10.100.1.1 255.255.255.0

speed 100

full-duplex

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.100.1.1

interface Serial1/0

description HQ-RTR

no ip address

encapsulation frame-relay IETF

serial restart-delay 0

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 201 interface Serial1/1 101

frame-relay route 202 interface Serial1/2 102

interface Serial1/1

description BR1-RTR

no ip address

encapsulation frame-relay IETF

no fair-queue

serial restart-delay 0

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 101 interface Serial1/0 201

interface Serial1/2

description BR2-RTR

no ip address

encapsulation frame-relay IETF

serial restart-delay 0

frame-relay lmi-type ansi

frame-relay intf-type dce

frame-relay route 102 interface Serial1/0 202

ip route 10.11.1.0 255.255.255.0 10.100.1.2

ip route 10.12.1.0 255.255.255.0 10.100.1.3

ip route 10.13.1.0 255.255.255.0 10.100.1.4

tftp-server flash:P00307020200.bin

tftp-server flash:P00307020200.loads

tftp-server flash:P00307020200.sb2

tftp-server flash:P00307020200.sbn

dial-peer voice 2000 voip

destination-pattern 1011111...

session target ipv4:10.11.1.254

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

dial-peer voice 3000 voip

destination-pattern 2022222...

session target ipv4:10.12.1.254

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

dial-peer voice 4000 voip

destination-pattern 3033333...

session target ipv4:10.13.1.254

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

dial-peer voice 1 voip

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

telephony-service

load 7960-7940 P00307020200

max-ephones 1

max-dn 5

ip source-address 10.100.1.1 port 2000

ephone-dn 1 dual-line

number 911

ephone-dn 2 dual-line

number 1015551111

ephone-dn 3 dual-line

number 2025552222

ephone-dn 4 dual-line

number 3035553333

ephone-dn 5 dual-line

number 55987654321

ephone 1

mac-address 0000.0000.0000

type 7960

button 1:1 2:2 3:3 4:4 5:5

gateway

END CONFIG

Will this be adequate enough for our labbing purposes or should we look at getting an ADTRAN to simulate the PSTN? Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (4 ratings)
Loading.
UCcomp2007 Sun, 10/21/2007 - 16:08

I asked the same question a while back and got some good advice. I have three voice gateways. Gateway one and Gateway two are connected to CM environment. Each of those has a T1 interface. Each T1 is setup to get clocking from the line. Under Serial 0/0:23 I added line ISDN Protocol-emulate USER

Then I have a seperate Gateway with two T1 interfaces, running CME (not part of CM environment). I configured this CME routers T1's to be the Network side (ISDN Protocol-emulate Network) and provided the clocking to the other gateways. I use this CME gateway to act as a PSTN node. You will need a T1 back to back cable to connect the T1's together.

adandrade Thu, 11/29/2007 - 14:51

You could get a PCI 4-T1 card (350USD) and a cheap P3 PC with at least 256M and install and configure ASTERISK and you are done.

Advantages

1.- Get a PSTN Simulator (T1 or E1) for 450 USD

2.- You get to learn some useful ASTERISK skills.

ccbootcamp Fri, 11/30/2007 - 09:43

We use a 2811 (CME) w/ PVDM2s, VWIC-2MFT-T1, VWIC-2MFT-E1, NM-4A/S (for frame-relay). Make sure you have the correct files on the flash as well to handle CME:

(yes, there are some extra files you wont need for your PSTN sim, I just have all the CME files on the flash)

-------------------------------------

PSTN Router Show flash:

PSTN-WAN#sh fla

-#- --length-- -----date/time------ path

1 491213 Mar 29 2007 18:23:26 -07:00 128MB.sdf (NOT NEEDED FOR VoIP, just for IPS)

2 4308 Aug 30 2005 15:56:58 -07:00 admin_user.html

3 642871 Aug 30 2005 15:57:00 -07:00 admin_user.js

4 16369 Oct 12 2005 11:01:18 -07:00 app-b-acd-2.1.0.0.ReadMe

5 24679 Oct 12 2005 11:01:18 -07:00 app-b-acd-2.1.0.0.tcl

6 33870 Oct 12 2005 11:01:32 -07:00 app-b-acd-aa-2.1.0.0.tcl

7 281506 Jul 29 2004 12:54:12 -07:00 ATA030100SCCP040211A.zup

8 34023596 Jul 17 2007 19:49:38 -07:00 c2800nm-adventerprisek9_ivs-mz.124-3g.bin

9 1602 Aug 30 2005 15:57:00 -07:00 CiscoLogo.gif

10 638 Sep 16 2005 15:12:40 -07:00 CME_GUI_README.TXT

11 331101 Feb 08 2005 14:26:46 -08:00 CP7902060000SCCP050124A.sbin

12 338897 Feb 08 2005 14:26:46 -08:00 CP7905060000SCCP050124A.sbin

13 338481 Feb 08 2005 14:26:46 -08:00 CP7905060000SCCP050124A.zup

14 340247 Feb 08 2005 14:26:46 -08:00 CP7912060000SCCP050124A.sbin

15 953 Aug 30 2005 15:57:00 -07:00 Delete.gif

16 16344 Aug 30 2005 15:57:00 -07:00 DOM.JS

17 864 Aug 30 2005 15:57:00 -07:00 downarrow.gif

18 75650 Oct 26 2004 12:27:28 -07:00 en_bacd_allagentsbusy.au

19 83291 Oct 26 2004 12:27:28 -07:00 en_bacd_disconnect.au

20 63055 Oct 26 2004 12:27:28 -07:00 en_bacd_enter_dest.au

21 37952 Oct 26 2004 12:27:28 -07:00 en_bacd_invalidoption.au

22 496521 Dec 17 2001 12:16:28 -08:00 en_bacd_music_on_hold.au

23 123446 Oct 26 2004 12:27:28 -07:00 en_bacd_options_menu.au

24 42978 Mar 31 2005 11:17:40 -08:00 en_bacd_welcome.au

25 6146 Aug 30 2005 15:57:00 -07:00 ephone_admin.html

26 4658 Aug 30 2005 15:57:00 -07:00 LOGOHOME.GIF

27 496521 Mar 29 2004 13:40:48 -08:00 music-on-hold.au

28 3724 Aug 30 2005 15:57:00 -07:00 normal_user.html

29 77200 Sep 16 2005 15:12:04 -07:00 normal_user.js

30 128792 May 09 2005 19:32:24 -07:00 P00307020200.bin

31 458 May 09 2005 19:32:36 -07:00 P00307020200.loads

32 680394 May 09 2005 19:32:32 -07:00 P00307020200.sb2

33 129196 May 09 2005 19:32:28 -07:00 P00307020200.sbn

34 333822 Jul 29 2004 12:53:46 -07:00 P00403020214.bin

35 1908762 Aug 04 2004 15:43:46 -07:00 P00503010100.bin

36 1347 Aug 30 2005 15:57:00 -07:00 Plus.gif

37 47904 Jul 29 2004 12:53:46 -07:00 S00103020002.bin

38 49169 Sep 08 2004 18:35:46 -07:00 S00104000100.sbn

39 843 Aug 30 2005 15:57:00 -07:00 SXICONAD.GIF

40 174 Aug 30 2005 15:57:00 -07:00 Tab.gif

41 2392 Nov 10 2005 13:44:34 -08:00 telephony_service.html

42 870 Aug 30 2005 15:57:00 -07:00 UPARROW.GIF

43 3311 Aug 30 2005 15:57:00 -07:00 xml.template

44 9968 Aug 30 2005 15:57:00 -07:00 xml-test.html

----------------------------------

PSTN config:

http://www.ccbootcamp.com/download/Voice/Files-For-NLIs-CCIE-Voice-Lab-Workbook/base-configs/PSTN-v3.txt

-brad

http://www.ccbootcamp.com

(please rate the post)

Actions

This Discussion