UK Numbering Plan Problem

Unanswered Question
Oct 19th, 2007

Hello can someone assist. I am trying to use the UK numbering plan. This will be the first site that I am using it, at other sites I have entered the route patterns manually.

I have a pattern setup with 9.@ When I make a call I see it arriving at the gateway. I can see the number being dialed on the ISDN but the call never connects, the called phone never rings. I have done a debug q931 output and the only difference i notice between the UKNP and manual RPs is that the called party number is set to Plan:ISDN and Type:National on the call using the UKNP whereas on the call using the manula RP both these entries in the q931 trace are set to Unknown.

Does anyone know what is going on?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
ibutterw Fri, 10/19/2007 - 08:06

Plan:ISDN and Type:National won't work in the UK. They must be unknown. You could override it with a voice translation pattern if you are using h323 gateway, but the point is that the GBNP should NOT be setting these fields.

Just downloaded any looked at the latest one and it IS setting the patterns wrongly! Each pattern in the dialplan definition file has either T:N or T:I set against it. Wrong, Wrong, Wrong! Its a bug - open a tac case and get them to fix it!! They need to take these out so that the calls go out as unknown.

roy_fisher Sat, 10/27/2007 - 07:55


Just upgraded out dial plan to 1-1-5 and had this problem on our BT only ISDN 30.

C&W worked fine.




dezoconnor Sat, 10/27/2007 - 09:15

Excellent, we're not alone with this one then!! We recently upgraded this for one of our customers and ran into the same issue. Has anyone raised with TAC?

stevo1664 Sun, 12/02/2007 - 05:51

Excellent, so the UK Numbering Plan has an apparently intentional setting which means it doesn't work in the UK.

The Bug report says:

For Windows based CCM, Manually Edit the UKNP and add the required flag

T: I (for International)

T: N (for National)

Has anyone any idea how to do this?

Many Thanks

allan.thomas Sun, 12/02/2007 - 13:42

You can update the plan manually, however it only takes effect every time you cycle the CallManager service. The file is located in c:\Program files\Cisco\DialPlan\.

What you also need to be aware of is that that DNA also needs restarting for DNA to reflect the change.

Hope this helps.


stevo1664 Fri, 12/07/2007 - 09:31

I didn't have to edit my dial-plan in the end, I went into the H.323 gateway settings and set the following in the Outbound Calls section:

Called party IE number type unknown: Unknown

Called Numbering Plan: Unknown

Hope this helps

Patrick Colbeck Fri, 01/25/2008 - 06:35

Just tried UK dialplan again this afternoon and that indeed made it work.

Thanks very much. Now for some filters :)


This Discussion