HSRP config issue

Unanswered Question
Oct 19th, 2007
User Badges:

I am working on a redesign of our network. Since we don't want to reconfigure all of our /28-/30 subnets to allow for extra IP addresses to be available, we would like to do the following.


7507-1

interface Ethernet0/1/2

description *******

ip address 10.abc.39.1 255.255.255.0

full-duplex

standby 10 ip public_ip.abc.39.1

standby 10 priority 120

standby 10 preempt

standby 10 authentication *******

standby 10 name *******



7507-2

interface Ethernet0/1/2

description *******

ip address 10.abc.39.2 255.255.255.0

full-duplex

standby 10 ip public_ip.abc.39.1

standby 10 preempt

standby 10 authentication *******

standby 10 name *******



We have a lot of secondary addresses on our current interfaces, we will moving these to a sub-interface using vlans to provide better control.


If using the private range as the primary will that be an issue? Would we be better using an IP unnumbered config against the loopback of the router for all of the interfaces?


Trying to find the best way to not have to re-ip all of our clients. That would cause a nightmare to get everyone switched over. Plus a lot of work.


It is a lot easier rolling out HSRP or VRRP from the start than trying to re-engineer the network after the fact.


The interface is actually going to be a FastE and not Ethernet as listed above.


Thanks for any suggestions.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 10/19/2007 - 05:41
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The cleanest migration would be configuring dot1q trunking on the router's LAN interface.


Example,


interface f0/1.10

encapsulation dot1q 10

ip address 10.abc.39.2 255.255.255.0


interface f0/1.100

encapsulation dot1q 100

ip address public_ip.abc.39.1 255.255.255.0


The switch connecting to this link must be a trunk port and have Vlan 10 and 100 configured on its Vlan database.


The clients can be move as needed from Vlan 10 to Vlan 100 after they are re-ip.


HTH,



paarlberg Fri, 10/19/2007 - 05:56
User Badges:

We are trying to avoid redoing the IP addressing for over 100 clients. You can imagine how much of a hassle this will be. Most are utilizing the full /28 or /29. They are also hosting services that will require DNS and firewall updates, etc..


Will HSRP work with ip unnumbered on the interface/sub-interface? then the standby is set to the correct gw for the client? Would using a private address work as well for the interface/sub-interface address?

Edison Ortiz Fri, 10/19/2007 - 06:21
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

My proposal does not involve changing the IP addresses right away. My proposal involves segmenting your network the proper way.


You are proposing running two IP subnets over the same broadcast domain. Your proposal may work but you will be facing complex troubleshooting issues that I can't even begin to imagine.


Read my proposal carefully. Play around in a lab environment and let us know how it works out.

Actions

This Discussion