Any body know how to fix this 2900XLswitch problem

Unanswered Question

Switch2900Xl#

%IP-4-CLASS: Bad IP address and mask 0.0.0.0/32 in class_resolve()

%LINK-5-BOOTP: VLAN1 address 0.0.0.0, resolved by 192.168.1.250

%IP-4-CLASS: Bad IP address and mask 0.0.0.0/32 in class_resolve()

%LINK-5-BOOTP: VLAN1 address 0.0.0.0, resolved by 192.168.1.250

%IP-4-CLASS: Bad IP address and mask 0.0.0.0/32 in class_resolve()

%LINK-5-BOOTP: VLAN1 address 0.0.0.0, resolved by 192.168.1.250

%IP-4-CLASS: Bad IP address and mask 0.0.0.0/32 in class_resolve()

%LINK-5-BOOTP: VLAN1 address 0.0.0.0, resolved by 192.168.1.250

%IP-4-CLASS: Bad IP address and mask 0.0.0.0/32 in class_resolve()

%LINK-5-BOOTP: VLAN1 address 0.0.0.0, resolved by 192.168.1.250


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 10/19/2007 - 12:34
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

It sounds like you haven't assigned an IP to Vlan1 (management Vlan on 2900XL) and the switch is trying to obtain any IP via DHCP.


Manually enter an IP under interface Vlan1 or shutdown the interface if you aren't planning to use it for management.

Edison Ortiz Fri, 10/19/2007 - 13:43
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

please post the switch config.

version 11.2

no service pad

no service udp-small-serversctive help system 0.0.0.0/32

no service tcp-small-servers

!

hostname Switch2900XL Set system'

!n

!w

no ip routing0.0.0.0, reso

!e

interface VLAN150sk

no ip route-cache Sele

!

interface FastEthernet0/1

% Invalid inp

!

interface FastEthernet0/2

ip

!

interface FastEthernet0/3k

!

interface FastEthernet0/7

!

interface FastEthernet0/8ac-address-table

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

!

line con 0

stopbits 1

line vty 0 4

login

!

end


Edison Ortiz Fri, 10/19/2007 - 14:44
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

enter the following commands:


configuration terminal

interface Vlan1

shutdown

end

wr t


Are you still seeing those errors after this ?

Edison Ortiz Fri, 10/19/2007 - 17:05
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

give it a valid ip address with the following commands,


configuration terminal

interface vlan1

ip address 192.168.1.1 255.255.255.0

end

wr


___________


Please replace the ip address above with an IP address that is within your network. This IP address must be reserved and no other device should use it. This way you can telnet to the switch from remote and manage it just like you are doing from the console port.

Actions

This Discussion