EIGRP Routing

Answered Question
Oct 19th, 2007
User Badges:

Our corporation consists of over 24 sister companies all able to route to each other thru our parent company. Each of the 24 companies has a T1 to the parent in a hub/spoke configuration. The routing is provided via EIGRP on Cisco routers and of the 24 companies each has a dozen class C private IP networks. Many of the companies have subnetted their class C addresses to accommodate small networks that connect to them via VPN on broadband. These small networks are able to route traffic to the sister company to which they connect (VPN tunnel terminates) but are unable to route that traffic beyond the sister company. This has recently become an issue when one of the small networks via VPN at one sister company needed to access resources at another but the traffic from this network was not able to route past the sister company which it connects. We believe the issue is that the EIGRP tables do not have the routing information of the small network on the VPN connection. Is there a change that can be done on the EIGRP configuration at that sister company which will propagate to the others allowing routing to the small networks on the VPN connections?


Thank you for any help.

Correct Answer by Edison Ortiz about 9 years 7 months ago

router eigrp x

redistribute static metric 1 1 1 1 1


More info can be found at:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124cg/hirp_c/ch20/piconfig.htm#wp1001056


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Fri, 10/19/2007 - 13:30
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You need to verify if there is any distribute-list under the EIGRP process that is blocking the announcement of those networks.


Without seeing the configs and the expected routing table, it's very hard to offer any suggestions.

tilconny1 Fri, 10/19/2007 - 14:04
User Badges:

I can post the EIGRP configuration if that will help. I don't think the remote networks would be known to the primary or advertise themselves as they are a VPN network (via SonicWall).

Thank you.

Edison Ortiz Fri, 10/19/2007 - 14:23
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

That explains it. You will need a GRE tunnel in order to have EIGRP routing going via the VPN.

tilconny1 Mon, 10/22/2007 - 04:35
User Badges:

We don't need EIGRP across the VPN tunnels but we need in the routing tables the information that in order to get to these remote networks how to get to them. For example, in order for me to get to a remote network at one of my sister companies the traffic would route appropriately to that sister company's primary Cisco router who does know how to get to that remote VPN network (static entry provided by the admin pointing to the SonicWall which is the endpoint for the remote network).

Static routes to these remote networks would be too cumbersome due to the hops in the middle. I was wondering if an entry can be made in the EIGRP configuration that would propagate thru the EIGRP tables providing the information of how to get to the remote networks via that sister company's router.


Thanks for any help.

Edison Ortiz Mon, 10/22/2007 - 08:54
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Routing is what provides that information and you have 2 choices.


Choice one, dynamic routing in the form of EIGRP

Choice two, static routing


You've mentioned static routing would cause a lot of work hence your only choice is dynamic routing so you need to advertise those networks with this routing protocol.


You can have both, static and dynamic. A router may have static routes and redistribute those static routes into EIGRP for the rest of the network.


I don't understand your topology really well, if you have a network diagram, post it.



tilconny1 Mon, 10/22/2007 - 09:31
User Badges:

Edison,


Thank you for your reply. Below is a sample diagram of what we have as the parent will have about 24 sister companies with associated T1s. The goal is to have the users on the remote small VPN network at company D to access resources at company A, B and C. Because company A, B and C do not have the information for the small remote network at company D in their routing tables traffic cannot get back to their network.

I have also included what the EIGRP configuration looks like at the sister company 2600 routers.


Thank you for any help.


sister company A

2600 Router with EIGRP

|

(T1)

|

Parent company

3800 router with EIGRP

|

(T1)

|

2600 router with EIGRP

sister company D

|

(Broadband-SonicWall VPN)

|

Small Remote Network


router eigrp 210

redistribute connected

redistribute static route-map default

passive-interface Serial2/0.1

network 10.0.0.0

no auto-summary


route-map default permit 10

match ip address 1

tilconny1 Tue, 10/30/2007 - 13:57
User Badges:

Edison,


You mentioned the following: "You can have both, static and dynamic. A router may have static routes and redistribute those static routes into EIGRP for the rest of the network."

This may be our answer if at that sister company we have the static routes pointing to the VPN appliance for these networks and also have them redistribute in EIGRP. Could you let me know if this is possible and/or point me in direction of how I can accomplish this?


Thanks again for any help.

Jeff

Actions

This Discussion