problem with downloading a IOS

Answered Question
Oct 21st, 2007


I need to download the IOS 12.4(11)T. I went to :

and clicked on :

"Cisco IOS Software"

The authentication is always failed when I type in my CISCO account and password.

Why does this happen? I'm sure I didn't make mistakes on typing. Do I need to register another high level account(if it exist) to obtain the IOS?

Thanks in advance.


I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 9 years 3 months ago

If you need 12.4(9)T2 then 2610 is a bad choice.

The last code release that supports the 2610 hardware is 12.3(23)

Correct Answer by Edison Ortiz about 9 years 3 months ago

No, it does not.

Correct Answer by Edison Ortiz about 9 years 3 months ago

1)You can check on eBay for used Cisco 2610

2)2600XM is not the current model, the current model is the 2800 Series. For price range, see :

3)It will work on the 2600XM

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (11 ratings)
Edison Ortiz Sun, 10/21/2007 - 18:29

The account you are trying to use must be associated to an existing contract in order to be allowed to download IOS software.

Go to and click on Login at the top of the page. If the authentication fails, you will be instructed on where to send a request to have the account reset.

insert7992 Sun, 10/21/2007 - 18:48

Thanks for your help.

I tried to login as you suggested. The login is successful but I still have the same problem. That is:

after I login, I click the "Cisco IOS Software ", a pop up authentication window ask for my acc_name and password, then the previous password failed and following information appeared:


We Apologize

The page you are trying to access requires a user name and password.

You have reached this page for one of the following reasons:

You have entered an invalid user name/password combination. If you feel this is an error, please try to login again.

You have forgotten your password.

Forgot Your User Name or Password?

Reset your password

Not Registered?

Benefits of registering

Register now

Has your password been reset?

Your Cisco password may have been reset. To receive your new password, send a blank e-mail from the account which you entered upon registration to [email protected].

If You Are Still Not Able to Log In

Reactivate your username:

If you have not logged in within the last 12 months you may need to reactivate your account.

Reset your password:

Send a blank e-mail to [email protected]. An automatic check will verify that your e-mail address is registered with If successful, you will receive your account details with a new random password via e-mail.

Complete the registration process by validating your email address:

Please check the e-mail account that you entered when you registered for a profile. Click on or cut-and-paste the URL into a browser address window to return to and confirm your e-mail address to complete the registration.

You must complete this final step before you can log in to


I tried to reset my password several times and it just didn't work.

In you post, you mentioned "associated to an existing contract ", does this mean I need to do some special setting somewhere or do I have to buy a router before I can download IOS software.

Thanks a lot.


Richard Burts Mon, 10/22/2007 - 02:55


It would appear that your CCO login does not have sufficient privilege for downloading software. Cisco makes it possible for many people to get a login ID which allows them to see and use many features of CCO. But some features (including download of software) require a higher privilege level. As suggested by Edison usually it requires associating the login ID with an active maintenance contract on some Cisco equipment to get the software download privilege. Is your ID associated with an active maintenance contract?



Edison Ortiz Mon, 10/22/2007 - 05:01

Try this, go to, click on Login.

After Login, click on Profile (right next to Login) on that page. Enter your credentials once again, click on Additional Access.

Under Your Access, you should have a Service Contract Owner link.

Click there,

a) if you have contracts listed - you should be allowed to download IOS only if your contract is still valid.

b) if you don't have contracts listed and you've purchased a smartnet contract, click on Obtain access to additional Service Contracts

c) if you haven't purchased a smartnet contract or your contract has been invalidated , you aren't allowed to download IOS.

insert7992 Mon, 10/22/2007 - 15:47

Thanks to both rburts and EdisonOrtiz. I see the point now.

Several more questions please. I saw on CISCO website, CISCO2610 router are no longer available since 2003, and was replaced by CISCO2600XM router.

(1).Is it possible I can buy a used CISCO2610 on CISCO or somewhere else?

(2).Can you give me the price range for a CISCO2600XM router?

(3).Does IOS12.4(11)T work with CISCO2610 or CISCO2600XM?

Thank you very much.


insert7992 Mon, 10/22/2007 - 17:46

Thank you very much for your information.

I'm sorry that I should have said "and" for the third question. Namely, does IOS12.4(11)T works on the 2610 too?

Thanks again.

insert7992 Mon, 10/22/2007 - 18:15

Thank you for your very useful information.

Then which version can be run on 2610? In order to run Squid2.6 and for some other purpose, I need at least 12.4(9)T2 for a working router. Is that possible? Or Does it mean that 2610 is a very bad choice?

Correct Answer
Edison Ortiz Tue, 10/23/2007 - 05:59

If you need 12.4(9)T2 then 2610 is a bad choice.

The last code release that supports the 2610 hardware is 12.3(23)

insert7992 Tue, 10/23/2007 - 08:06

Thanks to both of you.

Some documentation says that if we want a router work with WCCP, loading 12.3T(any version) is a very bad choice, is that true?

If this is true, as EdisonOrtiz recommended, I will have to consider choosing 2610XM and 12.4(11)T, although it's more expensive. Would you guys give me some confirmation advise on this setting so that I can make sure it works with WCCP and Squid2.6?


Edison Ortiz Tue, 10/23/2007 - 13:51

If you are looking for WCCP support, it will work on any version 12.0 and later on the 2610.

Can you post the link where it says that configuring WCCP on 12.3T is bad ?

insert7992 Tue, 10/23/2007 - 14:38

As you said, WCCP is claimed to be work with many routers. I'm trying to make Squid2.6 and WCCP work together by following the experience from:

The author sames to have tested many IOS versions, but as he said, he worked on some low end routers--maybe that's one of the problems(not sure).

In my case, I will work on 2610XM router(ordered one today), so I'd like to follow his advise and asked the dealer to load IOS12.4(11)T into my router.

I will appreciate if you can give me some advise.

Edison Ortiz Tue, 10/23/2007 - 14:52

WCCP is just a redirector and most of the work is done by the web cache engine, in this case Squid.

I'm not familiar with Squid so I won't be able to give you any advise on that.

Edison Ortiz Tue, 10/23/2007 - 15:07

BTW, I reviewed the link you posted and I believe he is referring to this bug:


Bug Details


No WCCP/CEF support in C1700-ADVSECURITYK9-M image





Components Duplicate of

Severity 3 Severity help Status Resolved Status help

First Found-in Version 12.3 All affected versions First Fixed-in Version 12.3(12.5), 12.3(12.6)T, 12.3(11)T06, 12.3(8)T09, 12.3(11)YW Version help

Release Notes


Redirection by WCCP does not occur in the ADVSECURITYK9 image.


Both WCCP and CEF are enabled.


Redirection will work if CEF is disabled. However before this is done the performance implications

should be considered. An alternative is to use a different image variant for the platform if the

features of ADVSECURITYK9 are not required.

insert7992 Tue, 10/23/2007 - 18:23


Do I need to warry about this WCCP/CEF bugs in the combination of 12.4(11)T and 2610XM? In addition, I'm not quite understand the bug details you showed me. Is it because of image object?(this could be a naive question)

Edison Ortiz Tue, 10/23/2007 - 19:50

No, you don't need to worry on 12.4(11)T and versions listed above such as:

12.3(12.5), 12.3(12.6)T, 12.3(11)T06, 12.3(8)T09, 12.3(11)YW

insert7992 Tue, 10/23/2007 - 19:59

Thank you for all your help. I really mean it. It will take for ever to set up my experiment system without your kindly help.


This Discussion