Provide Internet Resolving to Client PCs - DNS from Provider

Unanswered Question
Oct 21st, 2007

Hi All,

I am trying to configure a network with the following scenario:

Pc --> Switch --> Router --> T1 Data Connection

I have the data connection working with NAT / PAT to my client PC's within the network. I can reach the internal (10.1.x.x) / external network via ping. However, I cannot resolve internet addresses from the client PC's. I can resolve internet addresses from my router (ie ping www.google.com returns the correct info). From what I undertand, I should put the router's address as the DNS Primary server on the PC's network config, then have the router's serial address (internet facing connection) contain an ACL that allows DNS udp traffic?

Can you verify why the following ACL is not working for my connection?

!

interface Serial0/0/1:0

ip address 12.X.X.X 255.255.255.X

ip nat outside

ip virtual-reassembly

encapsulation ppp

crypto map CM

service-policy output VOIP

!

ip nat inside source route-map RMAP_1 interface Serial0/0/1:0 overload

access-list 101 permit ip 10.1.0.0 0.0.255.255 any

access-list 101 permit udp any any eq domain

access-list 101 permit udp any eq domain any

route-map RMAP_1 permit 1

match ip address 101

I appreciate any assistance with the topic.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
jabranzahid Sun, 10/21/2007 - 21:26

Hi,

You will need to use your service provider's DNS server addresses on your PC. Your router isn't providing any translation services.

Hope that helps..

Jabran Zahid

tomtom001 Mon, 10/22/2007 - 04:30

Hi,

Thank you for the reply. I tried inputting the provider's DNS settings on the client PC and I'm still not able to get internet html pages on the computer. The addresses are not resolving to IP's. I can ping external IP addresses, but cannot ping web addresses such as google.com. Is there another access list that I am missing?

Thanks again for your help.

Paolo Bevilacqua Mon, 10/22/2007 - 04:34

If the router can ping by name, and is runnign a recent IOS, configure:

ip domain-lookup

ip dns server

and use router's address as DNS on the PCs.

Hope this helps, please rate post if it does!

tomtom001 Mon, 10/22/2007 - 06:39

Thank you.

Using those commands fixed the issue.

I appreciate your help!

Actions

This Discussion