7960 does not parse XML

Unanswered Question
Oct 22nd, 2007


I have an 7960 and an 7970. I have installed the sample applications on IIS 6.

The 7970 parses the output fine. The 7960 doesn't. It gives:







<Data> etc.....

Anyone any idee where to start looking?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Mike-1985 Mon, 10/22/2007 - 00:59

Could you please post the full xml you are sending to the IP Phones? So I can test it here for you ;-)

leeflang Mon, 10/22/2007 - 01:21

Yes, i can. I hope it is helpfull. The sample app is out the Cisco Phone SDK, so i assumed it should work.

Are there differences in the way the phone parses the Xml between an 7970 and 7960?

Mike-1985 Mon, 10/22/2007 - 05:07

I've tested it on a 7940 and 7960... both works fine. Haven't tested it on 7970 because it was in use for other development.

so the code seemd fine to me. I couldn't find anything strange.

What does your 7960 give as response? Does it shows the xml as plain text on the ip phone?

leeflang Mon, 10/22/2007 - 05:11

My 7970 and 7921 works also fine. The 7960 just shows the plain text of the Xml.

Can you give me the version of firmware you use in the 7960? I can try the same verion, so i can rule that out. Now i am running with P00308000400.

leeflang Mon, 10/22/2007 - 06:18

Thank you, i will give it a try tomorrow and let you know if it is an version issue!

leeflang Tue, 10/23/2007 - 04:27

Well i've updates my phone. Now i have also:

App Load ID:


Boot Load ID:


But still no xml application, only text :-(

Do you know any other options?

leeflang Wed, 10/24/2007 - 05:19

Well, i figured it out. It's a little bit weird. I had the application under the questionmark button. That did work under the 7970 but not under the 7960.

Now i have configured the application under the services button and it works like a charm.

Weird that it works anyway on the 7970, But solved for one happy cisco geek (me).

bbuck2002 Sun, 10/28/2007 - 22:00

I am having this exact same problem except I am actually using the SERVICES button and am still just getting the XML output. Has anyone a clue on what might be happening? I verified that the "content-type: text/xml" header is being sent to the client, and it does work properly in IP communicator. I am using 7960/40 as well with 8.0(4.0) firmware. Thanks in advance for any help!

leeflang Tue, 10/30/2007 - 06:20

Well, so it should be something in the code. Have you also tried to install the sample codes from the Cisco Ip Phone SDK?

Also, can you attacht the problematic file, so i can test it in my scenario.

bbuck2002 Tue, 10/30/2007 - 07:17

I was able to work around the problem. It seems that loading an ASP based menu for the starting point when hitting the services key is not supported, but it does work as an option from the menu. So to resolve the issue, I now have a static menu.xml file as my entry point when hitting the services key, and the asp based scripts are selected from the main menu, and this works great. I am guessing this is a quirk with the 7940/60, because it only was a problem on those models.

leeflang Tue, 10/30/2007 - 07:58

Well oke, thanks for the info. It may be usefull for me in the future.

Happy Xml-ling!

pklos Tue, 10/23/2007 - 01:13

Before text XML you should send http header like this "content-type:text/xml".




leeflang Tue, 10/23/2007 - 03:44

Thanks for your input. My file is an ASP. It has Response.ContentType= "text/xml" in the code.

pklos Tue, 10/23/2007 - 07:23

Run Ethereal or Network Monitor and check sniffed packets for received headers and xml content. Sometimes header that you receive is different bacause its overwritten by IIS.





This Discussion