Router on a Stick and VLANs Problem

Unanswered Question
Oct 22nd, 2007


I have a router and 2950 switch setup as a "router stick". Here is a brief of the config I am using.


int f0/1

no ip address

int f0/1.1

encap dot1q 1

ip address

int f0/1.2

encap dot1q 2

ip address

int f0/1.3

encap dot1q 3

ip address

ip helper-address


int f0/1

switchport multi vlan 1-250

switchport mode multi

int f0/2

switchport access vlan 2

int f0.3

switchport access vlan 3

When we plug any device into port 3 on our switch, we get no where. Cant ping the vlan gateway on our router at all. Management for this switch is on vlan 1, can access without issue. We have an access point on vlan 2 (directly connected to port 2 on the switch), this is fully accessible.

Were testing the thrid vlan (3), plug laptop into port 3 on switch and we get no IP, and can not ping gateway.

Any ideas?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jesse Hottle Mon, 10/22/2007 - 07:53


DHCP is right. Even if I static an IP, still cant ping out. Its like the switch is not making the connected device a member if its port vlan.


moses12315 Mon, 10/22/2007 - 08:00

I have sometimes a similar problem with switch ports. Sometimes some ports at a switch do not work, and i do not know why. I change the port at the switch and it works. Try to change the port for vlan 3 (etc f0/10) and see what will happen.

Jesse Hottle Mon, 10/22/2007 - 08:04


I tried that, and no luck. I just want the switch and router sub-interface to be on the same vlan link, but I want anything connected to this switch port to auto become a vlan member and be able to pass traffic. This switch does not like this process. I am going to try another switch. This is driving me nut that it wont work. I mean, its a simnple setup.

moses12315 Mon, 10/22/2007 - 08:22

Yes you are right it's not so difficult configuration. What i usually do is i configure the port at the switch which is connected to the router as a trunk link. Then i configure the router and the switch as you did. I can not see the problem. I do not remember facing this problem before.

Good luck.


ankbhasi Mon, 10/22/2007 - 08:54

Hi Friend,

Can you try changing switchport mode as trunk instead if multivlan and see if that helps? As far my understanding goes router subinterface is expecting vlan 3 traffic as tag and multivlan port does not send tag traffic and it will be dropped at the router interface.



Jesse Hottle Mon, 10/22/2007 - 09:26


I do not have this option on my switch. Only multi. I was also going to test this with a different 2950, but the software image is standard and wont let me setup encapsulation per port... Looks like I am SOL.


glen.grant Mon, 10/22/2007 - 11:07

Sounds like you need to upgrade the 2950 code to something more recent , any 2950 I have seen supports trunking. What version are you running ? The latest code is 12.1.22ea10 .

ankbhasi Mon, 10/22/2007 - 20:30

Hi Jesse,

Do you have 2950 or 2900XL switch? On 2950 you do not need to configure encapsulation as it bydefault and only supports dot1q.

So if you issue a command "switchport mode trunk" that should be enough.



Tsasbrink Thu, 10/25/2007 - 00:59

You are actualy not running a dot1q trunk on your switch.

Since switchport multi means that the vlans mentioned are sent untagged only the default vlan will work.

On the 2950 trunk to your router you should configure :

switchport mode trunk

switchport trunk encapsulation dot1q

All 2950 should support this command, the 2924XL series come in two flavours, en 4Mb version and a 8Mb version, the 4Mb version does not support trunking.


This Discussion