HP GBE2c to 6500 Etherchannel

Unanswered Question

Hey guys,

I wonder if you can help me. Unfortunately the people above me decided to order the HP blade server with the HP Ethernet switches inside, rather than the Cisco ones (3020) and now I'm left to try and get them going!

My idea is to basically give each blade machine/server an ip (so there'll be 16 of those), all on differing VLAN's, but always between 205-209 and have two trunk uplinks to the 6500 etherchannelled together to give a 2Gb uplink. The DG of the machines will be the FWSM of the 6500, so the switches should just forward anything to the uplink trunk ports and the 6500.

So, for example the config on the cisco side is for one of the ports would be:

interface GigabitEthernet1/44

description bladesw1

no ip address

speed 1000

duplex full

switchport

switchport mode trunk

switchport trunk allowed vlan 205-209

channel-group 10 mode on

with:

interface Port-channel10

description Etherchannel to LivetestBladeServerSW1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 205-209

switchport mode trunk

On the other side of things the docs seem to say that you just create a trunkgroup, add the ports to it and away you go but I'm unsure if it's talking about a 'trunk' i.e. lots of VLANs going down the same pipe or an Etherchannel group - combining two ports to make one big one???

I've added an IP address for VLAN205 on the HP switch and while I can ping that when there's no etherchannel configuration i.e. switchport mode access, switchport access vlan205 - I can't ping it when I attempt the etherchannel.

The thing is that it looks like the Etherchannel is up, with show etherchannel 10 detail showing:

Group state = L2

Ports: 1 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Ports in the group:

-------------------

Port: Gi1/44

------------

Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl

Channel group = 10 Mode = Passive Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po10

Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

A - Device is in active mode. P - Device is in passive mode.

Local information:

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi1/44 SP indep 32768 0xA 0xA 0x12C 0x7C

Age of the port in the current state: 0d:00h:01m:41s

Port-channels in the group:

----------------------

Port-channel: Po10 (Primary Aggregator)

------------

Age of the Port-channel = 3d:07h:19m:37s

Logical slot/port = 14/6 Number of ports = 0

Port state = Port-channel Ag-Not-Inuse

Protocol = LACP

Time since last port bundled: 0d:01h:32m:25s Gi1/44

Time since last port Un-bundled: 0d:01h:20m:59s Gi1/44

Thanks in advance for any help you can give me!

Anthony

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
tstanik Fri, 10/26/2007 - 11:19

A trunkgroup is a group of same type of trunks. In your case you can configure trunkports for the connection between servers and switches. In etherchannel config when you try to ping and you are get error "Remote host not responding" it means that the ping packets are not able to reach the host or are getting dropped. Check the config of etherchannel again to make sure that the packets are able to pass through the etherchannel.

Actions

This Discussion