Cannot ping local interface of router

Unanswered Question
Oct 22nd, 2007

I have a router with 2 lan interfaces and 2 loopback addresses. All interfaces show up/up. The router is passing traffic. I can ping all interfaces from a device on either segment. I can ping hosts on both segments from both segments. What I cannot do is ping one of the local interfaces from the router itself. I can ping both loopbacks and one of the interfaces just fine. I have tried directed pings from all of the interfaces to the one that is not working, to no avail. I can do a directed ping from this interface to hosts on either segment. I have tried debugs but due to the volume of traffic on the router I have not had much success. I do not believe this to be applicable but the interface displaying the problem is token-ring, the router is a 3662 and I am going to replace the token ring module to eliminate it. I am just curious to know if anyone else has seen a similar symptom. Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Mon, 10/22/2007 - 16:04

Do you have an ACL on that interface ?

Do you have devices on that segment ?

David Smith Tue, 10/23/2007 - 05:50

No ACL, yes to devices on that segment. It was hardware. Replaced the NM and all is now well. Thanks.

Nagaraja Thanthry Tue, 10/23/2007 - 04:18

Hi,

As per my knowledge, there are some interface types on Cisco Routers which do not support self PING. Typically these are all point-to-point interfaces. I am assuming that feature has also been extended to Token Ring interface. I may be wrong.

Konstantin Dunaev Tue, 10/23/2007 - 04:23

hi,

for point-to-point interfaces the self-ping goes via the remote interface (you can easly see it with ping, as the RRT doubled), for ethernet interfaces it was not the case, the router does the ping realy locally, but how does it look like for the token-ring interface I don't know.

Actions

This Discussion