Bandwidth Reservation

Unanswered Question
Oct 22nd, 2007

Hi.

I asked yesterday about the to reserve some bandwidth to a specific ip on my router.

the case is that we have a 2600 router with two fastethernet interfaces. connected to the ISP with 18M bandwidth and the other to the local network. We have 32 public IPs and i want to give one of the IPs a reserved bandwidth of 1M.

i get some help and also get some links about QoS.

well. finally i make some configuration on the router as follows

!

!

class-map match-all class1

match access-group 101

!

!

policy-map thaer

class class1

bandwidth 1024

!

!

access-list 101

permit ip host X.X.X.X any

!

Is this enough ?? can i apply the policy map to the internal interface now??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
guruprasadr Mon, 10/22/2007 - 23:08

HI,

I feel this is OK but define the implicit class as "class class-default" to use rest of 17M of Bandwidth for other traffic.

!

policy-map thaer

class class1

bandwidth 1024

class class-default

fair-queue

!

Apply to the interface connected to LAN segment with "service-policy output thaer"

Pls be clear about some points:

1. What type of trffic is being routed via this Public IP

2. Is this IP is reserved for one particular LAN.

3. Where is rest of the 17M of Bandwidth is going to be used.

Hope I am Informative.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

thaershunnar Mon, 10/22/2007 - 23:17

Ok..

i think this ip is going to be used for some kind of video confrencing. it will be connected to one pc only.

the other 17M will continue to serve the rest of the uneversity i worked in, i.e they are used on the firewalls we have.

thaershunnar Tue, 10/23/2007 - 02:45

Hi again.

i did as you said. and the configuration are as follows.

!

class-map match-all class1

match access-group 101

!

!

policy-map thaer

class class1

bandwidth 5120

class class-default

fair-queue

!

interface FastEthernet0/0

ip address y.y.y.y 255.255.255.252

load-interval 30

duplex auto

speed auto

service-policy output thaer

!

!

access-list 101 permit ip host x.x.x.x any

!

But it did not work. every thing still the same.

i have the public ip x.x.x.x on my laptop now but i am not having the 5M as i configured.

any help ?

guruprasadr Tue, 10/23/2007 - 03:01

HI, [PLS RATE if HELPS]

In your previous explanation:

FaEth0/1 ==>connected to ISP

FaEth0/0 ==>connected to PC

PC and FaEth0/0 should be in the same IP Range to allow them ping each other in both direction.

I hope already the FaEth0/1 connected to ISP should be OK ?

You can create a NAT Statement (one-to-one mapping) to allow the local traffic reach the ISP Side.

In addition create a rate-limitter in the Interface connected to Service Provider:

==>FaEth0/1

rate-limit input access-group 101 5000000 2000 2000 conform-action transmit exceed-action drop

Note: For rest of the 13M of BW, create a another ACL defining IP @ Ranges with the rate limit applied for 13M of Usage.

Hope i am Informative.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

thaershunnar Tue, 10/23/2007 - 04:58

Hi.. thank you.

it seems that the rate limit done all the work.

i put two access groups one for the whole ips except the needed one and the other with the neede ip permited, also i configured two rate limit rules on the ISP interface. and it is done.

what i whant to know is: what is the point of the class-map and policy-map, it seems the do nothing ??

guruprasadr Tue, 10/23/2007 - 05:54

HI, [PLS RATE if HELPS]

Its nice to hear it worked for you.

Please POST your Configuration.

Answer for your question:

----------------------------------

With class-map you match all types of traffic in Router and define a Name for the Class initially.

==>You match an ACL for identifying particular range of traffic.

With Policy-map a Map name is defined and mutiple such class map can be defined inside policy-map and other parameters like bandwidth and etc., Note: class class-default is the implicit rule for other types of traffic where there is NO specific Class-map is defined and matched.

service-policy output

===>With this command using Class map and policy map the traffic is limited at the internal interface itself based on the requirement.

Neverthless, with rate-limit cofiguration the Service Provider traffic is Splitted.

For more INFO about QOS and Techniq:

End to End QOS Network Design

Author: By Tim Szigeti - CCIE No. 9794, Christina Hattingh

Hope I am Informative.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

Actions

This Discussion