IRB With 3750

Unanswered Question
Oct 23rd, 2007

I am doing some testing with IRB using 2 WS-C3750-12S switches. I have them connected using a point to point routed ethernet ports via multimode SFP's using OSPF as the routing protocol. They connect fine and all is well. We now need to bridge vlans acrross routed ports. I enabled IRB and created BVI 1 I then remove address off router port and assign ip address on BVI and add routed interfaces to bridge group 1. Because bridge protocol ieee is not available I use bridge protocol vlan-bridge on both routers. The result was a total loss of IP connectivity between routed interfaces. Here are configs please help!

Software Version 12.2(37)SE

hostname A3-C3750-RTR

!

switch 1 provision ws-c3750g-12s

system mtu routing 1500

ip subnet-zero

ip routing

ip host A3-router 10.177.32.1

ip host A1-router 10.177.0.1

ip host A3-switch 10.177.33.1

ip host A1-switch 10.177.1.1

!

ip dhcp pool test

!

no file verify auto

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

bridge irb

!

interface GigabitEthernet1/0/1

description A1-C3750

no switchport

no ip address

ip ospf network broadcast

bridge-group 1

!

interface GigabitEthernet1/0/11

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 10.177.32.1 255.255.240.0

!

interface Vlan201

no ip address

bridge-group 1

!

interface BVI1

ip address 10.178.0.1 255.255.255.254

!

router ospf 10

log-adjacency-changes

network 10.177.32.0 0.0.15.255 area 0

network 10.178.0.0 0.0.0.1 area 0

!

ip classless

ip http server

!

bridge 1 protocol vlan-bridge

!

control-plane

!

!

hostname A1-C3750-RTR

!

switch 1 provision ws-c3750g-12s

system mtu routing 1500

ip subnet-zero

ip routing

ip host A3-router 10.177.32.1

ip host A1-router 10.177.0.1

ip host A3-switch 10.177.33.1

ip host A1-switch 10.177.1.1

!

!

no file verify auto

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

bridge irb

!

interface GigabitEthernet1/0/1

description A3-C3750

no switchport

no ip address

ip ospf network broadcast

bridge-group 1

!

interface GigabitEthernet1/0/11

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan1

ip address 10.177.0.1 255.255.240.0

!

interface Vlan201

no ip address

bridge-group 1

!

interface BVI1

ip address 10.178.0.0 255.255.255.254

!

router ospf 10

log-adjacency-changes

network 10.177.0.0 0.0.15.255 area 0

network 10.178.0.0 0.0.0.1 area 0

!

ip classless

ip http server

!

bridge 1 protocol vlan-bridge

!

control-plane

!

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Tue, 10/23/2007 - 13:59

If you want to route IP on the bridge, you must enable it

bridge 1 route ip

I still don't understand what you are trying to achieve here. IRB on a switch ? Hmmm....

saitkenhead Wed, 10/24/2007 - 05:53

bridge 1 route ip was on config with no change. Cisco 3750 is a multi layer switch and I I have it connected to other 3750 using routed interface Gi 1/0/1.

interface GigabitEthernet1/0/1

description A3-C3750

no switchport

no ip address

ip ospf network broadcast

bridge-group 1

Edison Ortiz Wed, 10/24/2007 - 13:27

If you need to bridge a Vlan while routing another Vlan, there is no need to create an IRB.

IRB is used on routers to emulate switch behavior.

Yes, I'm fully aware the 3750 is a multilayer switch.

What you need to do is create a Layer2 trunk to bridge a single/multiple Vlans between switching devices and create SVI (Switch Virtual Interfaces) for routed subnets.

saitkenhead Thu, 10/25/2007 - 09:32

Did the research on SVI's thanks for the info but here is our scenario (please see attached image)

Vlan 1 does not need to talk to vlan 201 and visa versa (Vlan 201 is a secure network). Vlan 201 0nly needs to talk to to vlan 201 at a layer 2 level. I was using the 3750 and 2940s as a test bed for IRB because that is what I have available. 99 percent of our traffic goes over our routed core and works fine, however we recenlty added host to vlan 201 in area 2 and area 3. There is a proprietary protocol that is not routable in vlan 201 and obviously vlan 201 in area 1 is not the same as vlan 201 in areas 2 or 3. Just trying to flat switch vlan 201 accross routed core while keeping all other traffic (Vlan1)routable.Thought IRB was the perfect candidate and testing with WS-3750G-12S was a close as I could get to our 6509 multilayer devices.

Thank you for your patience. :)

Attachment: 
saro Thu, 10/25/2007 - 10:58

You can't do it. The 3750 does not support IRB or CRB or any of bridging features. It's a switch so therefor assumes you will use vlans for that function with SVI to route for said vlans. As was mentioned above, bridging makes a router act more like a switch and those features are for routers only.

From your drawing, you only have a few choices... you can span an L2 VLAN across the entire network (including 65ks) OR you can tunnel between the sites using devices that support L2 tunneling (not 65k). It looks like the links between teh 65ks are routed and therefor you don't have option 1. You could look into option 2... or if someone else has a better.

saitkenhead Fri, 10/26/2007 - 05:22

Thanks for your response. Makes you wonder why they have those commands (IRB CRB) available on the 3750 in the first place.

Edison Ortiz Fri, 10/26/2007 - 06:38

One of those things when running IOS feature set that also incorporate into regular routers. Those commands are available in routers but not supported in switches.

Check out this list:

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_35_se/configuration/guide/swuncli.html

As stated before, you get the same functionality by using SVI instead of BVI.

Kevin Dorrell Fri, 10/26/2007 - 07:00

Oh, that's a pity. I was hoping somehow to use a bridge between two VLAN to ease a VLAN migration. Back to the drawing board!

Kevin Dorrell

Luxembourg

Actions

This Discussion