CME with SIP ip phones and G.729

Unanswered Question
Oct 23rd, 2007

Hello,

Is it possible to connect SIP ip phones on cme sip server, and to communicate over G.729 codec?

It is working for G.711.

I know it is possible for SCCP ip phones.

Best regards.

Goran

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Paolo Bevilacqua Wed, 10/24/2007 - 02:38

Yes, it is possible.

Note that G.729 despite popular belief, it not well suited to use over the internet, due to bad quality in case of jitter and packet loss.

So if you are connecting phones over the Internet and the idea is of saving bandwidth, the best would be fo you to try the new phones (7942, 7962 etc) that the iLBC codec and that will be presumably supported in a next version of CME.

iLBC unlike G.729 behave very well in presence of impairment on the IP network.

Hope this helps, please rate post if it does!

goranr Wed, 10/24/2007 - 05:50

Thank you,

But I have two more questions about it.

1. I would like to connect Linksys IP Phone (SIP) to cme, but it is ok with G.711. With G.729 codec SIP says it has problem with media stream. Did you try to work with Cisco ip phones and do I need to configure anything else but codec g.729?

2. What will be the new version of IOS that will support iLBC?

Best regards,

Paolo Bevilacqua Wed, 10/24/2007 - 05:54

1. have you configured codec or voice-class under voice register pool ?

2. iLBC is already supported for generic voip use but not for phones as these came out just recently. Cisco has not specified when iLBC support for CME will be available.

goranr Wed, 10/24/2007 - 05:58

1. Yes, I configured codec G.729,and it is not possible to configure voice-class under voice register pool. Or I have old version of CME :-)?

Best regards

Paolo Bevilacqua Wed, 10/24/2007 - 06:09

Which IOS version do you have?

Anyway codec g.729 is enough, one would need to see with "debug ccsip message" why it fails.

goranr Wed, 10/24/2007 - 23:52

OK,

I solved my problem. It was my mistake. I tried with G.711 and it was working, but with G.729 it was not until I did not changed dtmf to go out of band. It makes sense.

Thank you and best regards.

Goran

Actions

This Discussion