3560 VTP problem

Answered Question
Oct 24th, 2007

I have 3 3560's on a fibre ring terminated on a gbic blade in a 6509.

The two gbic ports on the 6509 are configured 'set trunk n/n on dot1q'.

The gbic ports on the 3560's are 'switchport mode trunk'. I can ping all 3 3560's from the 6509 but I can only ping one of them from my P.C. The 3560 I can ping from my p>c is the one not connected to the 6509. VTP details are correct, all three 3560's can see all vlans. Any ideas?

I have this problem too.
0 votes
Correct Answer by mark.cronin about 9 years 1 month ago

Are you using a routing protocol on the 3560

like ospf or eigrp? No

You will need to add static routes to them pointing back to the 6509 address

ip route 0.0.0.0 0.0.0.0 192.168.2.2

or

ip route 0.0.0.0 0.0.0.0 192.168.2.1

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
glen.grant Wed, 10/24/2007 - 03:17

Check the default gateway setting on your nic card , it should be set as the layer 3 routing interface of the vlan you are attached to , from the DOS prompt issue the "ipconfig" command and it will show what gateway it is pointed at .

scarboroughbc Wed, 10/24/2007 - 03:33

Hi Glen

Thanks for the quick response.

My default gateway is OK as I can ping all other switches on vlan 1. All the other switches are 2950's and 3548's, its only the 3560's that are a problem.

Mike

mark.cronin Wed, 10/24/2007 - 05:06

Whats the IP address of each 3560 switches 1,2,3 and the 6509?

What VLAN are you using as management on the 3560?

What routes are on the 3560 switches? all should point back to the 6509 address.

scarboroughbc Wed, 10/24/2007 - 05:14

Hi Mark

The IP addresses of the 3560's are

192.168.2.86

192.168.2.87

192.168.2.88

The Management VLAN is 1

The 6509(router module)is 192.168.2.1, the default gateway of the 3560's.

The 6509 Sup2 is 192.168.2.2.

There are no routes defined on the 3560's.

I have been looking at the configs of the 3560's, the two that I cannot ping have the lines -

ip subnet-zero

ip routing

Could this cause the problem?

Mike

Correct Answer
mark.cronin Wed, 10/24/2007 - 05:18

Are you using a routing protocol on the 3560

like ospf or eigrp? No

You will need to add static routes to them pointing back to the 6509 address

ip route 0.0.0.0 0.0.0.0 192.168.2.2

or

ip route 0.0.0.0 0.0.0.0 192.168.2.1

scarboroughbc Wed, 10/24/2007 - 05:24

Hi Mark

I am not using any routing protocols on the 3560's.

I was told that I would not have to add any routes for VLAN 1.

Is that incorrect?

Mike

mark.cronin Wed, 10/24/2007 - 05:26

If your PC is on a different VLAN than VLAN 1

then the 3560 switches will need a default gateway to route traffic.

scarboroughbc Wed, 10/24/2007 - 05:34

Hi Mark

Added route to 192.168.2.1, I can now ping all the 3560's.

Thank you very much for your assistance.

Mike

Actions

This Discussion